Modify

Opened 8 years ago

Closed 7 years ago

#12893 closed defect (duplicate)

Mapillary import images in sequence fails.

Reported by: dr.kludge.gm@… Owned by: floscher
Priority: normal Milestone:
Component: Plugin mapillary Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Upgraded to latest version of Josm and plugins.
  2. File > Import Images into sequence.

What is the expected result?

I would see a list of files in the view are of josm.

What happens instead?

The File Open dialog opens. There is an error message is behind the file open dialog. The dos box has

INFO: AbstractTileSourceLayer: estimated visible tiles: 54, estimated cache size: 108
ERROR: java.lang.NegativeArraySizeException
java.lang.NegativeArraySizeException

at java.util.Arrays.copyOf(Unknown Source)
at org.openstreetmap.josm.plugins.mapillary.utils.ImageUtil$ImageFileFilter.accept(ImageUtil.java:150)
at javax.swing.JFileChooser.accept(Unknown Source)
at javax.swing.plaf.basic.BasicDirectoryModel$LoadFilesThread.run0(Unknown Source)
at javax.swing.plaf.basic.BasicDirectoryModel$LoadFilesThread.run(Unknown Source)

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-05-30 02:06:54 +0200 (Mon, 30 May 2016)
Build-Date:2016-05-30 01:32:45
Revision:10301
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10301 en) Windows 7 64-Bit
Memory Usage: 998 MB / 998 MB (859 MB allocated, but free)
Java version: 1.8.0_31-b13, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-XX:InitialCodeCacheSize=3M, -XX:ReservedCodeCacheSize=12M, -XX:NumberOfGCLogFiles=10, -XX:GCLogFileSize=8K, -Djosm.home=\gis\apps\josm, -Djosm.pref=\gis\apps\josm, -Djosm.cache=\gis\data\josm_temp, -Djosm.userdata=\gis\apps\josm\data_files]
Program arguments: [--debug, --set=lastDirectory=<josm.pref>\data_files, --set=mapillary.start-directory=C:\gis\data\osm_survey\mapillary, --set=search.history-size=40, --set=select.history-size=40]
Dataset consistency test: No problems found

Plugins:
- ColorPlugin (1414145445)
- CommandLine (32158)
- Create_grid_of_ways (32158)
- DirectDownload (32158)
- DirectUpload (32158)
- DxfImport (1006)
- FastDraw (32158)
- FixAddresses (32158)
- HouseNumberTaggingTool (31926)
- ImageWayPoint (32158)
- ImportImagePlugin (32158)
- Mapillary (32158)
- OpeningHoursEditor (32158)
- PicLayer (32158)
- RoadSigns (32177)
- ShapeTools (1000)
- alignways (32161)
- apache-commons (32158)
- apache-http (32158)
- buildings_tools (32158)
- conflation (0.2.0)
- continuosDownload (44)
- dataimport (31926)
- download_along (32158)
- editgpx (32158)
- ejml (32158)
- ext_tools (32158)
- geotools (31895)
- graphview (32158)
- imageryadjust (32158)
- jna (32158)
- jts (31906)
- junctionchecking (32158)
- lakewalker (32158)
- livegps (32158)
- log4j (32158)
- mbtiles (v2.0)
- measurement (32158)
- namemanager (32158)
- opendata (32158)
- openvisible (31772)
- osmarender (31772)
- pbf (32158)
- pdfimport (32158)
- photo_geotagging (32158)
- photoadjust (32158)
- poly (32158)
- print (32191)
- proj4j (32158)
- public_transport (32158)
- public_transport_layer (32158)
- reltoolbox (32158)
- reverter (32158)
- routes (32158)
- routing (32158)
- scripting (30722)
- tageditor (32158)
- tagging-preset-tester (32158)
- terracer (32158)
- todo (29154)
- touchscreenhelper (31923)
- turnlanes (32158)
- turnrestrictions (32158)
- undelete (32158)
- utilsplugin2 (32158)
- walkingpapers (32158)
- waydownloader (32158)
- wikipedia (32182)

Tagging presets:
- <josm.pref>\az_preset.xml

Map paint styles:
- http://dev.openseamap.org/josm/seamark_styles.xml
- http://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- http://www.openrailwaymap.org/styles/josm-additional.mapcss
- http://www.openrailwaymap.org/styles/maxspeed.mapcss
- http://www.openrailwaymap.org/styles/signals.mapcss
- http://www.openrailwaymap.org/styles/standard.mapcss
- https://github.com/simon04/coloured-addresses.mapcss/raw/master/dist/coloured-addresses.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Postcode&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_buildings&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/MaxspeedIcons&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Noname&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Power&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PowerMapping&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface-DataEntry&zip=1
- https://raw.github.com/molysgaard/OAM-JOSM/master/oam-style.mapcss
- https://raw.githubusercontent.com/species/josm-preset-traffic_sign_direction/master/direction.mapcss

Last errors/warnings:
- W:  Is In: Could not get presets icon images/styles/standard/misc/information.png
- E: Failed to locate image 'images/styles/standard/misc/information.png'
- W:  Wind Generator: Could not get presets icon images/styles/standard/misc/information.png
- E: java.lang.NegativeArraySizeException
- E: java.lang.NegativeArraySizeException

java.lang.NegativeArraySizeException
	at java.util.Arrays.copyOf(Unknown Source)
	at org.openstreetmap.josm.plugins.mapillary.utils.ImageUtil$ImageFileFilter.accept(ImageUtil.java:150)
	at javax.swing.JFileChooser.accept(Unknown Source)
	at javax.swing.plaf.basic.BasicDirectoryModel$LoadFilesThread.run0(Unknown Source)
	at javax.swing.plaf.basic.BasicDirectoryModel$LoadFilesThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 by Don-vip, 7 years ago

Component: CorePlugin mapillary
Owner: changed from team to floscher

comment:2 by Don-vip, 7 years ago

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13246.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain floscher.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.