Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12791 closed defect (fixed)

Progress state exception when doing various operations, object history, download notes, overpass export, etc.

Reported by: hjart Owned by: team
Priority: normal Milestone: 16.04
Component: Core Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Select object (node, way, etc)
  2. Press Ctrl-H

What is the expected result?

History window for the selected object appears.

What happens instead?

Error message dialogue appears

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-04-27 12:47:30 +0200 (Wed, 27 Apr 2016)
Build-Date:2016-04-28 01:32:01
Revision:10160
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10160 da) Linux openSUSE 13.2 (Harlequin) (x86_64)
Memory Usage: 615 MB / 1328 MB (88 MB allocated, but free)
Java version: 1.8.0_77-b03, Oracle Corporation, OpenJDK 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- ColorPlugin (1414145445)
- DirectUpload (31949)
- FastDraw (31895)
- ImproveOsm (39)
- InfoMode (31772)
- Mapillary (32040)
- SimplifyArea (31895)
- apache-commons (31895)
- apache-http (31895)
- areaselector (263)
- buildings_tools (31895)
- gpsblam (31772)
- log4j (31895)
- measurement (31895)
- rasterfilters (32146)
- reverter (32005)
- tag2link (31910)
- tagging-preset-tester (31895)
- todo (29154)
- tofix (1459464002)
- undelete (31895)
- utilsplugin2 (32099)
- wikipedia (32114)

Tagging presets:
- ${HOME}/OpenStreetMap/josm-stuff/HjartsPresets.xml
- http://somewhere.dk/email/josm/source.xml
- http://www.country-linedance.de/daten/Archaeologie-de.zip
- http://zibi.openstreetmap.org.pl/kendzi/k/Simple3dPreset/s3db-preset.zip
- https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Quick-highways&zip=1

Map paint styles:
- https://github.com/hotosm/HDM-JOSM-style/archive/master.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_features&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_features_ryg&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Ph_Typhoon&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&style&zip=1
- https://www.dropbox.com/s/qo3ai47fpv241jf/Styles_Fixme_and_Notes.zip?raw=1

Last errors/warnings:
- W: org.openstreetmap.josm.io.OsmTransferCanceledException: Operation canceled. Årsag: org.openstreetmap.josm.io.OsmTransferException: org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK. Årsag: org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK
- E: org.openstreetmap.josm.io.OsmTransferException: org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK. Årsag: org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK
- E: org.openstreetmap.josm.io.OsmTransferException: org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK. Årsag: org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK
- E: org.openstreetmap.josm.io.OsmTransferException: org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK. Årsag: org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK
- E: org.openstreetmap.josm.io.OsmTransferException: org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK. Årsag: org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK

org.openstreetmap.josm.io.OsmTransferException: org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK
	at org.openstreetmap.josm.io.OsmServerReader.getInputStreamRaw(OsmServerReader.java:176)
	at org.openstreetmap.josm.io.OsmServerReader.getInputStreamRaw(OsmServerReader.java:97)
	at org.openstreetmap.josm.io.OsmServerReader.getInputStream(OsmServerReader.java:61)
	at org.openstreetmap.josm.io.OsmServerReader.getInputStream(OsmServerReader.java:44)
	at org.openstreetmap.josm.io.OsmServerHistoryReader.parseHistory(OsmServerHistoryReader.java:65)
	at org.openstreetmap.josm.gui.history.HistoryLoadTask.loadHistory(HistoryLoadTask.java:194)
	at org.openstreetmap.josm.gui.history.HistoryLoadTask.realRun(HistoryLoadTask.java:179)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:161)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)
Caused by: org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK
	at org.openstreetmap.josm.gui.progress.AbstractProgressMonitor.checkState(AbstractProgressMonitor.java:69)
	at org.openstreetmap.josm.gui.progress.AbstractProgressMonitor.beginTask(AbstractProgressMonitor.java:84)
	at org.openstreetmap.josm.gui.progress.AbstractProgressMonitor.beginTask(AbstractProgressMonitor.java:78)
	at org.openstreetmap.josm.io.StreamProgressUpdater.initProgressMonitor(StreamProgressUpdater.java:30)
	at org.openstreetmap.josm.io.StreamProgressUpdater.<init>(StreamProgressUpdater.java:25)
	at org.openstreetmap.josm.io.ProgressInputStream.<init>(ProgressInputStream.java:36)
	at org.openstreetmap.josm.tools.HttpClient$Response.getContent(HttpClient.java:266)
	at org.openstreetmap.josm.io.OsmServerReader.getInputStreamRaw(OsmServerReader.java:172)
	... 13 more

Attachments (0)

Change History (14)

comment:1 Changed 4 years ago by DeeHants

Downloading notes does the same thing.
(Added to this bug as it's clearly the same cause)

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-04-27 12:47:30 +0200 (Wed, 27 Apr 2016)
Build-Date:2016-04-28 01:32:01
Revision:10160
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10160 en_GB) Windows 7 64-Bit
Memory Usage: 123 MB / 989 MB (25 MB allocated, but free)
Java version: 1.8.0_71-b15, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugins:
- InfoMode (31772)
- OpeningHoursEditor (31772)
- buildings_tools (31895)
- contourmerge (1014)
- gpsblam (31772)
- imageryadjust (31772)
- indoor_sweepline (32103)
- indoorhelper (32134)
- measurement (31895)
- public_transport (31895)
- public_transport_layer (32142)
- reverter (32005)
- splinex (31895)
- turnrestrictions (31895)
- undelete (31895)
- utilsplugin2 (32099)

Last errors/warnings:
- E: org.openstreetmap.josm.io.OsmTransferException: org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK. Cause: org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK
- E: org.openstreetmap.josm.io.OsmTransferException: org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK. Cause: org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK
- E: org.openstreetmap.josm.io.OsmTransferException: org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK. Cause: org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK
- E: org.openstreetmap.josm.io.OsmTransferException: org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK. Cause: org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK
- E: org.openstreetmap.josm.io.OsmTransferException: org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK. Cause: org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK

org.openstreetmap.josm.io.OsmTransferException: org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK
	at org.openstreetmap.josm.io.OsmServerReader.getInputStreamRaw(OsmServerReader.java:176)
	at org.openstreetmap.josm.io.OsmServerReader.getInputStreamRaw(OsmServerReader.java:97)
	at org.openstreetmap.josm.io.OsmServerReader.getInputStream(OsmServerReader.java:61)
	at org.openstreetmap.josm.io.OsmServerReader.getInputStream(OsmServerReader.java:44)
	at org.openstreetmap.josm.io.BoundingBoxDownloader.parseNotes(BoundingBoxDownloader.java:212)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadNotesTask$DownloadBoundingBoxTask.realRun(DownloadNotesTask.java:151)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:161)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
Caused by: org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK
	at org.openstreetmap.josm.gui.progress.AbstractProgressMonitor.checkState(AbstractProgressMonitor.java:69)
	at org.openstreetmap.josm.gui.progress.AbstractProgressMonitor.beginTask(AbstractProgressMonitor.java:84)
	at org.openstreetmap.josm.gui.progress.AbstractProgressMonitor.beginTask(AbstractProgressMonitor.java:78)
	at org.openstreetmap.josm.io.StreamProgressUpdater.initProgressMonitor(StreamProgressUpdater.java:30)
	at org.openstreetmap.josm.io.StreamProgressUpdater.<init>(StreamProgressUpdater.java:25)
	at org.openstreetmap.josm.io.ProgressInputStream.<init>(ProgressInputStream.java:36)
	at org.openstreetmap.josm.tools.HttpClient$Response.getContent(HttpClient.java:266)
	at org.openstreetmap.josm.io.OsmServerReader.getInputStreamRaw(OsmServerReader.java:172)
	... 12 more

comment:2 Changed 4 years ago by DeeHants

Ticket #12792 has been marked as a duplicate of this ticket.

comment:3 Changed 4 years ago by DeeHants

Ticket #12793 has been marked as a duplicate of this ticket.

comment:4 Changed 4 years ago by DeeHants

Ticket #12794 has been marked as a duplicate of this ticket.

comment:5 Changed 4 years ago by DeeHants

Ticket #12795 has been marked as a duplicate of this ticket.

comment:6 Changed 4 years ago by DeeHants

Summary: Error when trying to get history for an objectProgress state exception when doing various operations, object history, download notes, overpass export, etc.

comment:7 Changed 4 years ago by SergeyAstakhov

Ticket #12796 has been marked as a duplicate of this ticket.

comment:8 Changed 4 years ago by bastiK

Resolution: fixed
Status: newclosed

In 10161/josm:

fixed #12791 - Progress state exception when doing various operations

corrects typo in [10160]

comment:9 Changed 4 years ago by DeeHants

Ticket #12797 has been marked as a duplicate of this ticket.

comment:10 Changed 4 years ago by hjart

Ticket #12798 has been marked as a duplicate of this ticket.

comment:11 Changed 4 years ago by Don-vip

Keywords: regression added
Milestone: 16.04

breaking unit tests is not a good sign ;)

comment:12 Changed 4 years ago by Don-vip

org.openstreetmap.josm.tools.HttpClientTest.testPost and org.openstreetmap.josm.tools.HttpClientTest.testPostZero are still failing: we may still have a blocking problem here.

comment:13 Changed 4 years ago by Don-vip

Priority: normalblocker

comment:14 in reply to:  12 Changed 4 years ago by bastiK

Keywords: regression removed
Priority: blockernormal

I think this discussion belongs to #12583.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.