Modify

Opened 5 years ago

Closed 10 months ago

#12736 closed defect (duplicate)

JOSM is not warning about deleting nodes used by ways hidden by filters

Reported by: mkoniecz Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Delete node reused by hidden way

What is the expected result?

Warning, like for moving such nodes

What happens instead?

Nothing.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-04-03 19:25:25 +0200 (Sun, 03 Apr 2016)
Build-Date:2016-04-04 01:32:50
Revision:10108
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10108 en) Linux Ubuntu 14.04.4 LTS
Memory Usage: 465 MB / 889 MB (135 MB allocated, but free)
Java version: 1.8.0_77-b03, Oracle Corporation, Java HotSpot(TM) Server VM
Dataset consistency test: No problems found

Plugins:
- OpeningHoursEditor (31772)
- RoadSigns (31895)
- buildings_tools (31895)
- measurement (31895)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/LessObtrusiveNodes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lit&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LitObjects&zip=1

Validator rules:
- /home/mateusz/Documents/OSM/josm.validator.mapcss

Last errors/warnings:
- W: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out

Attachments (0)

Change History (1)

comment:1 Changed 10 months ago by Klumbumbus

Resolution: duplicate
Status: newclosed

Closed as duplicate of #19138.
Was fixed meanwhile.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.