Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#12704 closed defect (fixed)

Crash when switching on the indoor helper plugin

Reported by: DeeHants Owned by: team
Priority: major Milestone:
Component: Plugin Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Clicked "Power"

What is the expected result?

Not to crash :)

What happens instead?

It crashes :(

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-03-13 01:17:21 +0100 (Sun, 13 Mar 2016)
Build-Date:2016-03-13 02:35:00
Revision:9979
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9979 en_GB) Windows 7 64-Bit
Memory Usage: 123 MB / 989 MB (25 MB allocated, but free)
Java version: 1.8.0_71-b15, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugins:
- InfoMode (31772)
- OpeningHoursEditor (31772)
- buildings_tools (31895)
- contourmerge (1014)
- gpsblam (31772)
- imageryadjust (31772)
- indoor_sweepline (32103)
- indoorhelper (1458561683)
- measurement (31895)
- public_transport (31895)
- public_transport_layer (31932)
- reverter (32005)
- splinex (31895)
- turnrestrictions (31895)
- undelete (31895)
- utilsplugin2 (32099)

Last errors/warnings:
- E: java.lang.NoClassDefFoundError: org/openstreetmap/josm/data/Preferences$MapListSetting. Cause: java.lang.ClassNotFoundException: org.openstreetmap.josm.data.Preferences$MapListSetting

java.lang.NoClassDefFoundError: org/openstreetmap/josm/data/Preferences$MapListSetting
	at controller.IndoorHelperController.setPluginPreferences(IndoorHelperController.java:408)
	at controller.IndoorHelperController.access$300(IndoorHelperController.java:62)
	at controller.IndoorHelperController$ToolPowerButtonListener.actionPerformed(IndoorHelperController.java:141)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.JToggleButton$ToggleButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Caused by: java.lang.ClassNotFoundException: org.openstreetmap.josm.data.Preferences$MapListSetting
	at java.net.URLClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	... 40 more

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by Don-vip

Resolution: fixed
Status: newclosed

comment:2 Changed 3 years ago by Don-vip

Ticket #12702 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.