Modify

Opened 4 years ago

Closed 3 years ago

#12653 closed defect (wontfix)

WMS imagery in projection EPSG:25832 doesn't fill the screen

Reported by: TobWen Owned by: TobWen
Priority: normal Milestone:
Component: Plugin proj4j Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Set projection to custom EPSG 25832 (UTM 32N, very common in Europe)
  2. Load this WMS: http://geodaten.metropoleruhr.de/dop/dop
  3. Zoom to the area and scroll around.

What is the expected result?

It's expected to see the WMS image filling JOSM's complete background.

What happens instead?

Only a part of JOSM's background is filled by the WMS image (left side is black/blank).

Please provide any additional information below. Attach a screenshot if possible.

Screenshot: http://fs5.directupload.net/images/160319/likznkl6.jpg

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-03-19 01:51:36 +0100 (Sat, 19 Mar 2016)
Build-Date:2016-03-19 02:33:05
Revision:10012
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10012 de) Windows XP 32-Bit
Memory Usage: 399 MB / 910 MB (173 MB allocated, but free)
Java version: 1.8.0_73-b02, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Dsun.java2d.noddraw=false, -Dsun.java2d.ddoffscreen=true, -Dsun.java2d.ddscale=true, -Dsun.java2d.forceddvram=true]
Dataset consistency test: No problems found

Plugins:
- AddrInterpolation (31772)
- BuildingGeneralization (UNKNOWN)
- ColorPlugin (1414145445)
- CommandLine (31927)
- FastDraw (31895)
- FixAddresses (31772)
- HouseNumberTaggingTool (31772)
- ImportImagePlugin (31772)
- PicLayer (31895)
- RoadSigns (31895)
- ShapeTools (1000)
- SimplifyArea (31895)
- Tracer2 (32042)
- alignways (31895)
- apache-commons (31895)
- areaselector (263)
- buildings_tools (31895)
- conflation (0.1.9)
- continuosDownload (1446070193)
- contourmerge (1014)
- dataimport (31772)
- download_along (31772)
- ejml (31895)
- ext_tools (31772)
- geotools (31895)
- imagery_offset_db (32046)
- imageryadjust (31772)
- importvec (31772)
- jts (31772)
- junctionchecking (31772)
- log4j (31895)
- measurement (31895)
- merge-overlap (31967)
- namemanager (31772)
- opendata (32071)
- photo_geotagging (31895)
- photoadjust (32016)
- poly (31772)
- proj4j (32014)
- public_transport (31895)
- reltoolbox (31895)
- splinex (31895)
- surveyor2 (29210)
- turnrestrictions (31895)
- utilsplugin2 (32099)
- waydownloader (31772)

Last errors/warnings:
- E: Skipping to the next rule, because of an error:
- E: org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.ParseException: Encountered " <IDENT> "preset "" at line 1, column 19.

Attachments (1)

josm_dop_bug.jpg (306.5 KB) - added by TobWen 4 years ago.

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by TobWen

Attachment: josm_dop_bug.jpg added

comment:1 Changed 4 years ago by wiktorn

Owner: changed from team to TobWen
Status: newneedinfo

I can't reproduce. Is it this problem persistent, as you pan the map around , i.e. always left hand side is blank?

Can you share exact WMS url that you're using?

comment:2 Changed 4 years ago by TobWen

No, when panning the black area randomly in- and decreases between 25, 50 and 75 percent. Most of the time, it's about 50%.
I've alredy posted the extact WMS URL: http://geodaten.metropoleruhr.de/dop/dop

Edit: I've tested this on two other systems. One is running Windows XP, the other is running Windows 7. Both are multi-monitor environments. JOSM has bad problems with multi-monitors, but I don't think, that's a reson for the bug.

Last edited 4 years ago by TobWen (previous) (diff)

comment:3 Changed 4 years ago by wiktorn

Similar problem with multimonitor setup was fixed in #12050, and there the symptoms were similar.

Can you provide:

  • resolutions of all monitors that are connected
  • resolution of the monitor, on which you're working
  • can you look on Java console for messages like INFO: AbstractTileSourceLayer: estimated visible tiles: 77, estimated cache size: 154 and paste, what're the calculations on your environment?

FWIW: I'm testing on dual monitor setup: 1280x1024, 2560x1440, and I didn't notice any problems.

comment:4 Changed 4 years ago by TobWen

I only have access to one system right now. Resolution is 1280 x 1024 at 32 bit. All monitors have the same resolution.

Sure, here you go:

INFO: GET https://api.openstreetmap.org/api/0.6/map?bbox=7.5518346,51.4894535,7.5569415,51.4907362 -> 200
[INFO] CompositeCacheConfigurator - No special ElementAttribute class defined for key [jcs.region.WMS.elementattributes], using default class.
[INFO] AbstractDoubleLinkedListMemoryCache - initialized MemoryCache for WMS
[INFO] CompositeCache - Constructed cache with name [WMS] and cache attributes [ useLateral = true, useRemote = true, useDisk = true, maxObjs = 0, maxSpoolPerRun = -1, diskUsagePattern = UPDATE, spoolChunkSize = 2 ]
[INFO] IndexedDiskCache - Region [WMS] Cache file root directory: D:\josm\tiles
[INFO] IndexedDiskCache - Region [WMS] Set maxKeySize to: '524288'
[INFO] IndexedDiskCache - Region [WMS] Loaded keys from [WMS], key count: 2822; up to 524288 will be available.
[INFO] IndexedDiskCache - Region [WMS] Finished inital consistency check, isOk = true in 0ms.
[INFO] IndexedDiskCache - Region [WMS] Indexed Disk Cache is alive.
INFO: AbstractTileSourceLayer: estimated visible tiles: 12, estimated cache size: 24
INFO: GET http://geodaten.metropoleruhr.de/dop/dop?FORMAT=image/jpeg&VERSION=1.1.1&SERVICE=WMS&REQUEST=GetMap&LAYERS=dop&STYLES=&SRS=EPSG:25832&WIDTH=512&HEIGHT=512&BBOX=399714.6232000,5704955.8708397,400020.3713000,5705261.6189397 -> 200
INFO: GET http://geodaten.metropoleruhr.de/dop/dop?FORMAT=image/jpeg&VERSION=1.1.1&SERVICE=WMS&REQUEST=GetMap&LAYERS=dop&STYLES=&SRS=EPSG:25832&WIDTH=512&HEIGHT=512&BBOX=400020.3713000,5705261.6189397,400326.1194000,5705567.3670397 -> 200
INFO: GET http://geodaten.metropoleruhr.de/dop/dop?FORMAT=image/jpeg&VERSION=1.1.1&SERVICE=WMS&REQUEST=GetMap&LAYERS=dop&STYLES=&SRS=EPSG:25832&WIDTH=512&HEIGHT=512&BBOX=400020.3713000,5704955.8708397,400326.1194000,5705261.6189397 -> 200
INFO: GET http://geodaten.metropoleruhr.de/dop/dop?FORMAT=image/jpeg&VERSION=1.1.1&SERVICE=WMS&REQUEST=GetMap&LAYERS=dop&STYLES=&SRS=EPSG:25832&WIDTH=512&HEIGHT=512&BBOX=399714.6232000,5705261.6189397,400020.3713000,5705567.3670397 -> 200
[INFO] CacheEventQueue - Cache event queue created: CacheEventQueue [listenerId=-1813562190, cacheName=WMS]

Edit: I know your next question ;)
This image tile is located on the RIGHT of my current view! It doesn't get displayed. Seems like the viewport is shiftet to the right screen:

http://geodaten.metropoleruhr.de/dop/dop?FORMAT=image/jpeg&VERSION=1.1.1&SERVICE=WMS&REQUEST=GetMap&LAYERS=dop&STYLES=&SRS=EPSG:25832&WIDTH=512&HEIGHT=512&BBOX=400020.3713000,5705261.6189397,400326.1194000,5705567.3670397

Important: Starting a few versions ago, all the dialog-boxes are centered between the monitors again! This has been fixed a while ago and the boxes were placed on the primary monitor only. Right now, one needs to move the boxes to the left or right screen. JOSM is started on the primary screen only (fullscreen).

Last edited 4 years ago by TobWen (previous) (diff)

comment:5 Changed 4 years ago by wiktorn

Looks like we have calculated too small memory tile cache (24) for you. If I go to 1280x1024 I get:
INFO: AbstractTileSourceLayer: estimated visible tiles: 30, estimated cache size: 60

So my guess is, that for some strange reason, your screens are reported to Java VM as 640x480.

Did you update your graphic card drivers recently? Do this message change, if you remove your JVM options:
[-Dsun.java2d.noddraw=false, -Dsun.java2d.ddoffscreen=true, -Dsun.java2d.ddscale=true, -Dsun.java2d.forceddvram=true]
?

comment:6 Changed 4 years ago by Nakaner

I experience this bug with Berlin aerial imagery WMS. http://fbinter.stadt-berlin.de/fb/wms/senstadt/k_luftbild2014 The bug also occurs with my own WMS service (rendering railway lines).

The bug also occurs with EPSG:25833 (UTM zone 33N with ETRS89) and EPSG:3068 (Berlin Soldner projection). Both projections are conformal.

The bug does not occur with EPSG:31468 (Gauß-Krüger Streifen 4). This projection is conformal.

The bug does not occur with EPSG:4326 (WGS84, proj=latlon) and EPSG:3857 (Web-Mercator).

I can reproduce this bug with JOSM 9979 and 10037.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-03-24 20:46:34 +0100 (Thu, 24 Mar 2016)
Build-Date:2016-03-25 02:33:51
Revision:10037
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10037 de) Linux Ubuntu 15.10
Memory Usage: 279 MB / 855 MB (79 MB allocated, but free)
Java version: 1.8.0_66-internal-b17, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Djosm.restart=true, -Djosm.home=/home/michael/.josm-latest, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
- Mapillary (32040)
- OpeningHoursEditor (31772)
- PicLayer (31895)
- apache-commons (31895)
- apache-http (31895)
- buildings_tools (31895)
- pdfimport (32019)
- proj4j (32014)
- reverter (32005)
- terracer (31895)
- utilsplugin2 (32099)

Last errors/warnings:
- E: Fehler beim Laden des Bildes 'university.png'
- W:  University: Could not get presets icon university.png

comment:7 Changed 4 years ago by Nakaner

Component: CorePlugin proj4j

I think that this is a bug of proj4j plugin. I have deactivated the plugin and the bug does not occur any more.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-03-13 01:17:21 +0100 (Sun, 13 Mar 2016)
Build-Date:2016-03-13 02:35:00
Revision:9979
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9979 de) Linux Ubuntu 15.10
Memory Usage: 448 MB / 855 MB (101 MB allocated, but free)
Java version: 1.8.0_66-internal-b17, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
- Mapillary (32040)
- OpeningHoursEditor (31772)
- PicLayer (31895)
- apache-commons (31895)
- apache-http (31895)
- buildings_tools (31895)
- pdfimport (32019)
- reverter (32005)
- terracer (31895)
- utilsplugin2 (32099)

Last errors/warnings:
- E: Fehler beim Laden des Bildes 'university.png'
- W:  University: Could not get presets icon university.png

comment:8 Changed 3 years ago by Don-vip

Resolution: wontfix
Status: needinfoclosed

The plugin has been deprecated, most of its projections are now in JOSM core.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain TobWen.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.