Modify

Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#12050 closed defect (fixed)

Bing Imagery loading errors in josm version 8964

Reported by: west_lake Owned by: team
Priority: normal Milestone: 16.02
Component: Core imagery Version: latest
Keywords: Bing, latent Cc:

Description

Hello,

I updated to Josm Version 8964 three days ago and have experienced issues loading bing imagery. It will not load the image at certain zoom levels, but will load it at other levels. I have asked other users who have updated to 8964 and they are experience similar issues. A screenshot of the issue is attached.

Thanks!

Attachments (7)

Screen Shot 2015-11-02 at 9.41.58 AM.png (519.9 KB ) - added by West Lake 9 years ago.
bing_imagery_loading_error
dialog_12050.png (18.6 KB ) - added by mdk 8 years ago.
Proxi dialog on starting
Bildschirmfoto vom 2016-02-16 20-40-39.png (221.2 KB ) - added by mdk 8 years ago.
Problem downloading data
Bildschirmfoto vom 2016-02-16 22-12-12.png (273.4 KB ) - added by mdk 8 years ago.
download problems with r8798
tile_info_bing_tile_latency.png (49.8 KB ) - added by west_lake 8 years ago.
bing_tile_latency.png (934.6 KB ) - added by west_lake 8 years ago.
bing_tile_latency_resize.png (370.2 KB ) - added by west_lake 8 years ago.

Change History (23)

by West Lake, 9 years ago

bing_imagery_loading_error

comment:1 by west_lake, 8 years ago

Since submitting this, I have experienced the same issues in all stable releases after 8800.

Imagery tiles (bing,mapbox) render much less smoothly and do not render at certain zoom levels. Is there any reason the imagery tile rendering was changed in current releases.

Any information would be helpful.

Thanks

by mdk, 8 years ago

Attachment: dialog_12050.png added

Proxi dialog on starting

comment:2 by mdk, 8 years ago

I can confirm the problems with imagery.

But I also get problems on starting. To reproduce I manualle clean all single files from cache and start JOSM:
Proxi dialog on starting

After restarting JOSM starts correctly.

in reply to:  1 ; comment:3 by wiktorn, 8 years ago

Replying to west_lake:

Since submitting this, I have experienced the same issues in all stable releases after 8800.

Imagery tiles (bing,mapbox) render much less smoothly and do not render at certain zoom levels. Is there any reason the imagery tile rendering was changed in current releases.

Any information would be helpful.


If you run now version before 8800 then it's working correctly? What exactly are the errors that you see? I do not see any errors on your screen shot. If this problem occurs to you with latest stable version, can you:

  • right click on imagery tile, choose "show tile information", and attach a screen shot of it?
  • can you please provide all information that is automatically generated when you choose Help/Report bug?

by mdk, 8 years ago

Problem downloading data

comment:4 by mdk, 8 years ago

I also got problems downloading data since some time (I'm actually using r9807):
Problem downloading data

in reply to:  4 ; comment:5 by wiktorn, 8 years ago

Replying to mdk:

I also got problems downloading data since some time (I'm actually using r9807):

Please - let's separate the issue of data download and background imagery.

Does some older version (like <r8800 mentioned before) works flawlessly now, but latest JOSM version report such behaviour?

by mdk, 8 years ago

download problems with r8798

in reply to:  5 ; comment:6 by mdk, 8 years ago

Replying to wiktorn:

Replying to mdk:

I also got problems downloading data since some time (I'm actually using r9807):

Please - let's separate the issue of data download and background imagery.

Does some older version (like <r8800 mentioned before) works flawlessly now, but latest JOSM version report such behaviour?

I try r8798 and got the same error on startung (see screenshot "Bildschirmfoto vom 2016-02-16 22-12-12.png​").

But downloading OSM data works fine. So I try the same on r9807 and everything works fine too.

I see no real pattern. Some days every thing is fine and on other days nearly every second OSM download fails. But even on such days the upload always work! When I see an error message it's always a "connect timed out".

  • Is my internet connaction not ok? (I try rebooting my router, but it dosn't help)
  • Are there network problems on OSM side?
  • Could the switch to HTTPS have an impact? (for exapmle firefox complains about self signed certificates on sides like https://blog.openstreetmap.de/blog/2016/02/wochennotiz-nr-290/)
  • new Java version?
  • any other ideas what could have changed the last months?
Last edited 8 years ago by mdk (previous) (diff)

in reply to:  6 ; comment:7 by wiktorn, 8 years ago

Replying to mdk:

I try r8798 and got the same error on startung (see screenshot "Bildschirmfoto vom 2016-02-16 22-12-12.png​").

Then I guess that this is something else than reported here.

But downloading OSM data works fine. So I try the same on r9807 and everything works fine too.

I can't see a reason, why downloading OSM data works fine, and here you get timeouts. Does openning https://api.openstreetmap.org/api/capabilities in browser works fine?

I see no real pattern. Some days every thing is fine and on other days nearly every second OSM download fails. But even on such days the upload always work! When I see an error message it's always a "connect timed out".

connect time out looks like some network error. There were some IPv6 changes recently. Do you have IPv6 configured on your interfaces?

  • Is my internet connaction not ok? (I try rebooting my router, but it dosn't help)

If you can observe similar behaviour in for example web browser, that might be the case

  • Are there network problems on OSM side?

Hard to believe, there would be more people complaining

If there would be some problems with HTTPS I would expect some SSL related error instead of connection time out. So for now I'd rule this out.

  • new Java version?
  • any other ideas what could have changed the last months?

The only thing that comes to my mind is that you can try tcpdump/wireshark and capture the timeout and compare it to the situation when you open (I assume, flawlessly) the same address in browser (as for example - already mentioned https://api.openstreetmap.org/api/capabilities).

by west_lake, 8 years ago

by west_lake, 8 years ago

Attachment: bing_tile_latency.png added

in reply to:  7 comment:8 by mdk, 8 years ago

Replying to wiktorn:

Replying to mdk:

I try r8798 and got the same error on startung (see screenshot "Bildschirmfoto vom 2016-02-16 22-12-12.png​").

Then I guess that this is something else than reported here.

But downloading OSM data works fine. So I try the same on r9807 and everything works fine too.

I can't see a reason, why downloading OSM data works fine, and here you get timeouts. Does openning https://api.openstreetmap.org/api/capabilities in browser works fine?

As you can see on my screenshot above, I also get connect time out on OSM data - some times.
Getting capabilities from the browser works - right now.

I see no real pattern. Some days every thing is fine and on other days nearly every second OSM download fails. But even on such days the upload always work! When I see an error message it's always a "connect timed out".

connect time out looks like some network error. There were some IPv6 changes recently. Do you have IPv6 configured on your interfaces?

Yes. I use Ubuntu 15.10. with network defaults.

  • Is my internet connaction not ok? (I try rebooting my router, but it dosn't help)

If you can observe similar behaviour in for example web browser, that might be the case

not really...

  • Are there network problems on OSM side?

Hard to believe, there would be more people complaining

If there would be some problems with HTTPS I would expect some SSL related error instead of connection time out. So for now I'd rule this out.

  • new Java version?
  • any other ideas what could have changed the last months?

The only thing that comes to my mind is that you can try tcpdump/wireshark and capture the timeout and compare it to the situation when you open (I assume, flawlessly) the same address in browser (as for example - already mentioned https://api.openstreetmap.org/api/capabilities).

If it continue I will try. But first I have to become familar with these tools :)

by west_lake, 8 years ago

in reply to:  3 comment:9 by west_lake, 8 years ago

Replying to wiktorn:

Replying to west_lake:

Since submitting this, I have experienced the same issues in all stable releases after 8800.

Imagery tiles (bing,mapbox) render much less smoothly and do not render at certain zoom levels. Is there any reason the imagery tile rendering was changed in current releases.

Any information would be helpful.


If you run now version before 8800 then it's working correctly? What exactly are the errors that you see? I do not see any errors on your screen shot. If this problem occurs to you with latest stable version, can you:

  • right click on imagery tile, choose "show tile information", and attach a screen shot of it?
  • can you please provide all information that is automatically generated when you choose Help/Report bug?

Thanks for the response.

This issue occurs in all stable versions after 8800 for me and not in versions <=8800. The screenshot shows the imagery flickering. This flickering, a blank image or combination of the two happen at certain zoom levels but not at others. There also seems to be image tile loading latency in versions >8800 because in version 8800, the tiles load smoothly but in later versions, load blocky. hard to describe without a video.

Better screenshot:

Tile info:

Other info:

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-01-06 17:30:31 +0100 (Wed, 06 Jan 2016)
Build-Date:2016-01-06 16:32:31
Revision:9329
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9329 en) Mac OS X 10.11.1
Memory Usage: 3468 MB / 7282 MB (1121 MB allocated, but free)
Java version: 1.8.0_65, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- buildings_tools (31603)
- todo (29154)
- utilsplugin2 (31603)

Last errors/warnings:
- E: Failed to locate image 'bridge.png'
- W:  bridge: Could not get presets icon bridge.png
- E: Failed to locate image 'tunnel.png'
- W:  tunnel: Could not get presets icon tunnel.png
- E: Failed to locate image 'health/hospital.png'

comment:10 by mdk, 8 years ago

As a quick proof I disabled ipv6. I clear cache files and start JOSM several times without problems. I download OSM data for several areas also without problems. Even the browser feels "smoother" to work with. It looks like my ISP (Swisscom) may have some ipv6 problems. I will continue invastigating and report new findings ...

comment:11 by wiktorn, 8 years ago

In 9819/josm:

Add debug messages with estimates of cache size.

See: #12050

comment:12 by wiktorn, 8 years ago

@west_lake:

Can you try version later than r9819 and look for messages like that:

INFO: AbstractTileSourceLayer: estimated visible tiles: 77, estimated cache size: 154

And show me your results?

Also, can you tell me, what screen resolution do you have? Do you have multiple monitor setup?

in reply to:  12 comment:13 by west_lake, 8 years ago

Replying to wiktorn:

@west_lake:

Can you try version later than r9819 and look for messages like that:

INFO: AbstractTileSourceLayer: estimated visible tiles: 77, estimated cache size: 154

And show me your results?

Also, can you tell me, what screen resolution do you have? Do you have multiple monitor setup?

I ran the latest version I could find (9819) and here are the results:

INFO: AbstractTileSourceLayer: estimated visible tiles: 35, estimated cache size: 70

Yes, I am running JOSM on a secondary monitor (27 inch - 2560x1440).

I noticed yesterday that when JOSM is full-screen size on the secondary, the issue occurs, but when I run it on my primary monitor (15 inch) it does not. With 8800 - issue does not occur at all on either monitor.

comment:14 by wiktorn, 8 years ago

Resolution: fixed
Status: newclosed

In 9826/josm:

Properly support multi-display environments when estimating tile cache size.

Check for a monitor with display with biggest resolution instead of primary display to calculate the size of MemoryTileCache. This fixes problems with tiles on setups, where secondary monitor is bigger than primary, and user decides to work on secondary monitor.

Closes: #12050

comment:15 by west_lake, 8 years ago

@wiktorn Tested the fix and it has resolved the tile loading issue.

Thank you!

comment:16 by Klumbumbus, 8 years ago

Milestone: 16.02

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.