Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#12637 closed defect (fixed)

Errors when opening Mapbox imagery

Reported by: ak099 Owned by: team
Priority: major Milestone: 16.04
Component: Core imagery Version: latest
Keywords: mapbox errors npe Cc: wiktorn

Description

What steps will reproduce the problem?

  1. Opening Mapbox imagery

What is the expected result?

Opening imagery

What happens instead?

Mapbox imagery opens, but with many (about 10 or more) error message boxes "An unexpected exception occurred.<br>This is always a coding error. If you are running the latest<br>version of JOSM, please consider being kind and file a bug report."

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-03-17 02:02:14 +0100 (Thu, 17 Mar 2016)
Build-Date:2016-03-17 02:32:43
Revision:10003
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10003 ru) Windows 7 64-Bit
Memory Usage: 246 MB / 247 MB (87 MB allocated, but free)
Java version: 1.8.0_71-b15, Oracle Corporation, Java HotSpot(TM) Client VM

Plugins:
- HouseNumberTaggingTool (31772)
- OpeningHoursEditor (31772)
- buildings_tools (31895)
- imagery_offset_db (32046)
- indoor_sweepline (32103)
- jts (31772)
- log4j (31895)
- photoadjust (32016)
- reltoolbox (31895)
- utilsplugin2 (32099)

Last errors/warnings:
- E: java.lang.NullPointerException
- W: java.net.UnknownHostException: c.tiles.mapbox.com
- E: java.lang.NullPointerException
- W: java.net.UnknownHostException: c.tiles.mapbox.com
- E: java.lang.NullPointerException

java.lang.NullPointerException
	at java.security.MessageDigest.update(Unknown Source)
	at java.security.MessageDigest.digest(Unknown Source)
	at org.openstreetmap.gui.jmapviewer.tilesources.AbstractTMSTileSource.isNoTileAtZoom(AbstractTMSTileSource.java:196)
	at org.openstreetmap.josm.data.imagery.TMSCachedTileLoaderJob.isResponseLoadable(TMSCachedTileLoaderJob.java:134)
	at org.openstreetmap.josm.data.cache.JCSCachedTileLoaderJob.loadObject(JCSCachedTileLoaderJob.java:390)
	at org.openstreetmap.josm.data.cache.JCSCachedTileLoaderJob.run(JCSCachedTileLoaderJob.java:235)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (9)

comment:1 Changed 3 years ago by Don-vip

Component: CoreCore imagery
Keywords: npe added

comment:2 Changed 3 years ago by Don-vip

Cc: wiktorn added
Milestone: 16.03

comment:3 Changed 3 years ago by wiktorn

Fixed in [o32113]

comment:4 Changed 3 years ago by wiktorn

Resolution: fixed
Status: newclosed

comment:5 Changed 3 years ago by Don-vip

Milestone: 16.0316.04

Milestone renamed

comment:6 Changed 3 years ago by Don-vip

Ticket #12693 has been marked as a duplicate of this ticket.

comment:7 Changed 3 years ago by Don-vip

Ticket #12769 has been marked as a duplicate of this ticket.

comment:8 Changed 3 years ago by Don-vip

Ticket #12773 has been marked as a duplicate of this ticket.

comment:9 Changed 3 years ago by Don-vip

Priority: normalmajor

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.