Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#12560 closed defect (fixed)

NoSuchElementException while downloading relation members

Reported by: naoliv Owned by: team
Priority: normal Milestone: 16.02
Component: Core Version:
Keywords: regression Cc: simon04

Description

With the attached file, select all the 31 relations and ask to download the incomplete members.
Then we get this:

ERRO: java.util.NoSuchElementException. Causa: java.util.NoSuchElementException. Causa: java.util.NoSuchElementException
java.util.NoSuchElementException
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
	at java.util.concurrent.ForkJoinTask.getThrowableException(ForkJoinTask.java:598)
	at java.util.concurrent.ForkJoinTask.reportException(ForkJoinTask.java:677)
	at java.util.concurrent.ForkJoinTask.join(ForkJoinTask.java:720)
	at java.util.concurrent.ForkJoinPool.invoke(ForkJoinPool.java:2616)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer.render(StyledMapRenderer.java:1928)
	at org.openstreetmap.josm.gui.layer.OsmDataLayer.paint(OsmDataLayer.java:401)
	at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:643)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:727)
	at javax.swing.JComponent.paintChildren(JComponent.java:889)
	at javax.swing.JComponent.paint(JComponent.java:1065)
	at javax.swing.JComponent.paintChildren(JComponent.java:889)
	at javax.swing.JSplitPane.paintChildren(JSplitPane.java:1047)
	at javax.swing.JComponent.paint(JComponent.java:1065)
	at javax.swing.JComponent.paintChildren(JComponent.java:889)
	at javax.swing.JComponent.paint(JComponent.java:1065)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5210)
	at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:290)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1272)
	at javax.swing.JComponent._paintImmediately(JComponent.java:5158)
	at javax.swing.JComponent.paintImmediately(JComponent.java:4969)
	at javax.swing.RepaintManager$4.run(RepaintManager.java:831)
	at javax.swing.RepaintManager$4.run(RepaintManager.java:814)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:814)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:789)
	at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:738)
	at javax.swing.RepaintManager.access$1200(RepaintManager.java:64)
	at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1732)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:109)
	at java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:184)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:229)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:227)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:227)
	at java.awt.Dialog.show(Dialog.java:1084)
	at java.awt.Component.show(Component.java:1673)
	at java.awt.Component.setVisible(Component.java:1625)
	at java.awt.Window.setVisible(Window.java:1014)
	at java.awt.Dialog.setVisible(Dialog.java:1005)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$4.run(PleaseWaitProgressMonitor.java:197)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
Caused by: java.util.NoSuchElementException
	at org.openstreetmap.josm.tools.SubclassFilteredCollection$FilterIterator.next(SubclassFilteredCollection.java:55)
	at java.util.Collections.min(Collections.java:596)
	at org.openstreetmap.josm.gui.mappaint.mapcss.ExpressionFactory$MinMaxFunction.aggregateList(ExpressionFactory.java:1139)
	at org.openstreetmap.josm.gui.mappaint.mapcss.ExpressionFactory$MinMaxFunction.evaluate(ExpressionFactory.java:1152)
	at org.openstreetmap.josm.gui.mappaint.mapcss.ExpressionFactory$CondOperator.evaluate(ExpressionFactory.java:1021)
	at org.openstreetmap.josm.gui.mappaint.mapcss.ExpressionFactory$ParameterFunction.evaluate(ExpressionFactory.java:1200)
	at org.openstreetmap.josm.gui.mappaint.mapcss.Instruction$AssignmentInstruction.execute(Instruction.java:75)
	at org.openstreetmap.josm.gui.mappaint.mapcss.MapCSSRule$Declaration.execute(MapCSSRule.java:39)
	at org.openstreetmap.josm.gui.mappaint.mapcss.MapCSSRule.execute(MapCSSRule.java:79)
	at org.openstreetmap.josm.gui.mappaint.mapcss.MapCSSStyleSource.apply(MapCSSStyleSource.java:665)
	at org.openstreetmap.josm.gui.mappaint.ElemStyles.generateStyles(ElemStyles.java:342)
	at org.openstreetmap.josm.gui.mappaint.ElemStyles.getImpl(ElemStyles.java:306)
	at org.openstreetmap.josm.gui.mappaint.ElemStyles.getStyleCacheWithRange(ElemStyles.java:104)
	at org.openstreetmap.josm.gui.mappaint.ElemStyles.get(ElemStyles.java:83)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer$ComputeStyleListWorker.add(StyledMapRenderer.java:1877)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer$ComputeStyleListWorker.visit(StyledMapRenderer.java:1861)
	at org.openstreetmap.josm.data.osm.Relation.accept(Relation.java:164)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer$ComputeStyleListWorker.computeDirectly(StyledMapRenderer.java:1840)
	at org.open

JOSM:

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-02-23 02:11:42 +0100 (Tue, 23 Feb 2016)
Build-Date:2016-02-23 02:34:08
Revision:9854
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9854 pt_BR) Linux Debian GNU/Linux testing (stretch)
Memory Usage: 532 MB / 9102 MB (331 MB allocated, but free)
Java version: 1.8.0_72-internal-b05, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Dawt.useSystemAAFontSettings=on]

Plugins:
- Create_grid_of_ways (31772)
- OpeningHoursEditor (31772)
- PicLayer (31895)
- RoadSigns (31895)
- SimplifyArea (31895)
- apache-commons (31895)
- buildings_tools (31895)
- conflation (0.1.9)
- contourmerge (1014)
- download_along (31772)
- editgpx (31772)
- ejml (31895)
- geotools (31895)
- imagery_offset_db (32046)
- importvec (31772)
- jts (31772)
- log4j (31895)
- measurement (31895)
- merge-overlap (31967)
- opendata (32071)
- pbf (31772)
- pdfimport (32019)
- poly (31772)
- reverter (32005)
- scripting (30722)
- todo (29154)
- turnrestrictions (31895)
- undelete (31895)

Attachments (1)

data.osm (47.0 KB ) - added by naoliv 8 years ago.

Download all attachments as: .zip

Change History (4)

by naoliv, 8 years ago

Attachment: data.osm added

comment:1 by Don-vip, 8 years ago

Keywords: regression added
Milestone: 16.02

comment:2 by simon04, 8 years ago

Resolution: fixed
Status: newclosed

In 9859/josm:

see #12514, fix #12560 - Fix MapCSSParserTest#testMinMaxFunctions unit test + NoSuchElementException while downloading relation members

Regression of r9854

comment:3 by Don-vip, 8 years ago

Cc: simon04 added

@simon04: I have updated your commit message to reference this ticket, as it solves it :) Thanks! :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.