Modify

Opened 6 years ago

Closed 6 years ago

#12519 closed enhancement (duplicate)

Complain about railway=level_crossing on highway=footway

Reported by: mkoniecz Owned by: team
Priority: normal Milestone:
Component: Core validator Version:
Keywords: template_report Cc:

Description (last modified by mkoniecz)

What steps will reproduce the problem?

  1. create way, tag it highway=footway
  2. tag node on that way railway=level_crossing
  3. run validator

What is the expected result?

Validator complains that railway=crossing should be used (and if possible - provide automatic fix).

What happens instead?

Nothing.

Please provide any additional information below. Attach a screenshot if possible.

See http://wiki.openstreetmap.org/wiki/Tag:railway%3Dlevel_crossing http://wiki.openstreetmap.org/wiki/Tag:railway%3Dcrossing

Information that railway=level_crossing is not supposed to be used for pedestrian only corssings is not obvious for people that are not native speakers. See https://www.openstreetmap.org/changeset/37118079 that fixed my own tagging error - that I suspected only as result of my knowledge how default map style is rendering crossings.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-01-17 02:54:22 +0100 (Sun, 17 Jan 2016)
Build-Date:2016-01-17 02:34:22
Revision:9496
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9496 en) Linux Ubuntu 14.04.3 LTS
Memory Usage: 274 MB / 889 MB (79 MB allocated, but free)
Java version: 1.8.0_72-b15, Oracle Corporation, Java HotSpot(TM) Server VM
Dataset consistency test: No problems found

Plugins:
- OpeningHoursEditor (31772)
- RoadSigns (31895)
- measurement (31895)

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by mkoniecz

Description: modified (diff)

comment:2 Changed 6 years ago by naoliv

See #11270 also

comment:3 Changed 6 years ago by Klumbumbus

Resolution: duplicate
Status: newclosed

Closed as duplicate of #11270.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.