Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#12486 closed enhancement (fixed)

Sub second offset for picture and gpx correlation

Reported by: StephaneP Owned by: team
Priority: normal Milestone: 16.02
Component: Core Version:
Keywords: gpx; correlation; picture Cc:

Description

With the current Josm release, when correlating pictures with a gpx, you can offset the images with 1 second steps.
I could be useful to have smaller steps as in a car, 1 second could be a large range.

Attachments (2)

2016-02-05-002830_496x309_scrot.png (15.5 KB) - added by simon04 3 years ago.
2016-02-05-002845_410x288_scrot.png (7.2 KB) - added by simon04 3 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 3 years ago by simon04

Keywords: java added
Milestone: 16.04

Maybe we should await Java 8 and use java.time.Duration for passing around timezone and offset in org.openstreetmap.josm.gui.layer.geoimage.CorrelateGpxWithImages. Otherwise, the conversion between ms and s – back and forth – might easily be broken …

comment:2 Changed 3 years ago by simon04

Keywords: java removed
Milestone: 16.0416.02

Let's do it right away :)

comment:3 Changed 3 years ago by simon04

In 9741/josm:

see #12486 - Gpx/image correlation: factor out classes Timezone, Offset

comment:4 Changed 3 years ago by simon04

Resolution: fixed
Status: newclosed

In 9742/josm:

fix #12486 - Gpx/image correlation: allow sub-second offset

The textfield allows to input offsets in 1/1000s ("1.234" = 1234ms).
The seconds slider in the manual adjustment allows offsets of 1/10s.

Changed 3 years ago by simon04

Changed 3 years ago by simon04

comment:5 Changed 3 years ago by StephaneP

Thank you simon, it works perfectly !! :-D

comment:6 Changed 3 years ago by Don-vip

In 9752/josm:

see #12486 - findbugs

comment:7 Changed 3 years ago by bastiK

Ticket #11842 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.