Modify

Opened 4 years ago

Closed 4 years ago

#12474 closed defect (fixed)

java.lang.ClassCastException: java.lang.String cannot be cast to java.util.List

Reported by: naoliv Owned by: team
Priority: normal Milestone: 16.02
Component: Core imagery Version:
Keywords: regression Cc: wiktorn, stoecker

Description

I enabled the MapBox layer and got this:

AVISO: JCS - Exception during download http://c.tiles.mapbox.com/v4/openstreetmap.map-inh7ifmo/15/11705/18282.png?access_token=pk.eyJ1Ijoib3BlbnN0cmVldG1hcCIsImEiOiJncjlmd0t3In0.DmZsIeOW-3x-C5eX-wAqTw
AVISO: java.lang.ClassCastException: java.lang.String cannot be cast to java.util.List
java.lang.ClassCastException: java.lang.String cannot be cast to java.util.List
	at org.openstreetmap.gui.jmapviewer.tilesources.AbstractTMSTileSource.isNoTileAtZoom(AbstractTMSTileSource.java:178)
	at org.openstreetmap.josm.data.imagery.TMSCachedTileLoaderJob.isResponseLoadable(TMSCachedTileLoaderJob.java:134)
	at org.openstreetmap.josm.data.cache.JCSCachedTileLoaderJob.loadObject(JCSCachedTileLoaderJob.java:358)
	at org.openstreetmap.josm.data.cache.JCSCachedTileLoaderJob.run(JCSCachedTileLoaderJob.java:235)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)
AVISO: JCS - Silent failure during download: http://c.tiles.mapbox.com/v4/openstreetmap.map-inh7ifmo/15/11705/18282.png?access_token=pk.eyJ1Ijoib3BlbnN0cmVldG1hcCIsImEiOiJncjlmd0t3In0.DmZsIeOW-3x-C5eX-wAqTw

(actually a lot of this, one for each tile it seems)

JOSM:

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-01-31 16:21:47 +0100 (Sun, 31 Jan 2016)
Build-Date:2016-02-01 02:33:20
Revision:9702
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9702 pt_BR) Linux Debian GNU/Linux testing (stretch)
Memory Usage: 2647 MB / 9102 MB (2126 MB allocated, but free)
Java version: 1.8.0_72-internal-b05, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Dawt.useSystemAAFontSettings=on]
Dataset consistency test: No problems found

Plugins:
- Create_grid_of_ways (31772)
- OpeningHoursEditor (31772)
- PicLayer (31895)
- RoadSigns (31895)
- SimplifyArea (31895)
- apache-commons (31895)
- buildings_tools (31895)
- conflation (0.1.9)
- contourmerge (1014)
- download_along (31772)
- editgpx (31772)
- ejml (31895)
- geotools (31895)
- imagery_offset_db (31895)
- importvec (31772)
- jts (31772)
- log4j (31895)
- measurement (31895)
- merge-overlap (31967)
- opendata (31937)
- pbf (31772)
- pdfimport (32019)
- poly (31772)
- reverter (32005)
- scripting (30722)
- todo (29154)
- turnrestrictions (31895)
- undelete (31895)
- utilsplugin2 (32018)

Last errors/warnings:
- W: java.lang.ClassCastException: java.lang.String cannot be cast to java.util.List
- W: JCS - Silent failure during download: http://b.tiles.mapbox.com/v4/openstreetmap.map-inh7ifmo/15/11710/18280.png?access_token=pk.eyJ1Ijoib3BlbnN0cmVldG1hcCIsImEiOiJncjlmd0t3In0.DmZsIeOW-3x-C5eX-wAqTw
- W: JCS - Exception during download http://c.tiles.mapbox.com/v4/openstreetmap.map-inh7ifmo/15/11705/18282.png?access_token=pk.eyJ1Ijoib3BlbnN0cmVldG1hcCIsImEiOiJncjlmd0t3In0.DmZsIeOW-3x-C5eX-wAqTw
- W: java.lang.ClassCastException: java.lang.String cannot be cast to java.util.List
- W: JCS - Silent failure during download: http://c.tiles.mapbox.com/v4/openstreetmap.map-inh7ifmo/15/11705/18282.png?access_token=pk.eyJ1Ijoib3BlbnN0cmVldG1hcCIsImEiOiJncjlmd0t3In0.DmZsIeOW-3x-C5eX-wAqTw

Attachments (0)

Change History (6)

comment:1 Changed 4 years ago by wiktorn

Probably related to #12437

comment:2 Changed 4 years ago by stoecker

Milestone: 16.02

comment:3 Changed 4 years ago by naoliv

Ticket #12480 has been marked as a duplicate of this ticket.

comment:4 Changed 4 years ago by simon04

In 9713/josm:

see #12437 see #12474 - Add (failing) unit tests

comment:5 Changed 4 years ago by simon04

Cc: stoecker added
Keywords: regression added

comment:6 Changed 4 years ago by stoecker

Resolution: fixed
Status: newclosed

In 9715/josm:

fix #12474 - exception due to preferences update

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.