Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#12453 closed enhancement (fixed)

add icon for `discourage upload`

Reported by: Klumbumbus Owned by: team
Priority: minor Milestone: 16.02
Component: Core Version:
Keywords: Cc: Don-vip

Description (last modified by Klumbumbus)

For the context menu of a data layer in the layer list dialog. Here is an icon for this. I don't know which java files need to be changed.

Attachments (1)

no_upload.svg (4.5 KB) - added by Klumbumbus 3 years ago.

Download all attachments as: .zip

Change History (8)

Changed 3 years ago by Klumbumbus

Attachment: no_upload.svg added

comment:1 Changed 3 years ago by Klumbumbus

Description: modified (diff)

comment:2 Changed 3 years ago by stoecker

Owner: changed from team to Klumbumbus
Status: newneedinfo

Does this require a plugin to be installed?

comment:3 in reply to:  2 Changed 3 years ago by Klumbumbus

Owner: changed from Klumbumbus to team
Status: needinfonew

Replying to stoecker:

Does this require a plugin to be installed?

No, however I just realized that you need to manually set data.layer.upload_discouragement.menu_item to true.

This is one of the few josm entries, which doesn't have an icon.

comment:4 Changed 3 years ago by simon04

Resolution: fixed
Status: newclosed

In 9692/josm:

fix #12453 - Add icon for "discourage upload" (icon by Klumbumbus)

comment:5 Changed 3 years ago by simon04

Cc: Don-vip added

@Don-vip: shall we drop data.layer.upload_discouragement.menu_item (→ r5025)?

comment:6 Changed 3 years ago by simon04

In 9873/josm:

see #12453 - Display "discourage upload" in layer popup menu for experts

Removes the need to set data.layer.upload_discouragement.menu_item

comment:7 Changed 3 years ago by simon04

Ticket #11236 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.