Modify

Opened 5 years ago

Closed 5 years ago

#12451 closed defect (duplicate)

Hang opening at Default Settings

Reported by: Glassman Owned by: Glassman
Priority: normal Milestone:
Component: Core Version:
Keywords: linux Cc: sebastic

Description

Running latest, version 9645 on Xbuntu 15.10.

Unable to provide status report. JOSM never loads. It dies in the background. Reverted to tested which works fine.

Attachments (0)

Change History (10)

comment:1 Changed 5 years ago by Don-vip

Keywords: linux added
Owner: changed from team to Glassman
Status: newneedinfo

what's your version of Java? How do you launch JOSM?

comment:2 Changed 5 years ago by Glassman

java version 1.7.0.91

JOSM is run from the application menu.

comment:3 Changed 5 years ago by bastiK

You are using the josm-latest package from the https://josm.openstreetmap.de/apt repository?

If so, please run the application from the command line and report the output.

comment:4 Changed 5 years ago by mdk

Could it be the same problem as in #12332 and #12022?

Some weeks ago, the /etc/java-7-openjdk/accessibility.properties has deactivated assistive_technologies. Actually it looks like Ubuntu has been updated and assistive_technologies=org.GNOME.Accessibility.AtkWrapper is now activated.

Try edit /etc/java-7-openjdk/accessibility.properties and comment out the line assistive_technologies=org.GNOME.Accessibility.AtkWrapper.

comment:5 Changed 5 years ago by Glassman

commenting out assistive_technologies property solved the problem.

Running josm-latest from the command line works as expect, with or without commenting our accessibility.properties. It's only when run from the menu that it hangs.

Same results for version 9660.

also removed openjdk-7 and installed openjdk-8. josm-latest runs correctly from command line, fails from menu item. Menu item contains josm-latest %F.

comment:6 Changed 5 years ago by Don-vip

Cc: sebastic added

GNOME AtkWrapper really looks like pure crap (see not exhaustive list #12022 #12061 #12062 #12063 #12332), I wonder why OpenJDK maintainers enabled it by default... :(

@sebastic: do you have more information than we do?

comment:7 Changed 5 years ago by sebastic

Based on the changelog entry for openjdk-7 (7u85-2.6.1-6) it was re-enabled to fix Debian Bug #797595.

It may be worthwhile to raise this issue with the OpenJDK maintainers. They have fixed the other packages that had issues with the re-enabled AtkWrapper.

I don't use GNOME, and haven't experienced this issue personally.

comment:8 Changed 5 years ago by Don-vip

As far as I understand this is not specific with Gnome as most of users reporting issues aren't using it neither. Obviously this is not fixed (see the list of hang/crash bugs) and the software is unmaintained (last commit 6 months ago).

Can we ask to disable it again?

comment:9 Changed 5 years ago by sebastic

Can we ask to disable it again?

Of course. I suggest to report the related JOSM issues in the Debian bugreport too. The bugtracker is public, you don't need an account. See the bug reporting page.

comment:10 Changed 5 years ago by Don-vip

Resolution: duplicate
Status: needinfoclosed

Closed as duplicate of #12022.
thanks. I'll continue the follow-up on #12022

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Glassman.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.