Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12332 closed defect (duplicate)

Tag editor displays strange keys and values when (single-)clicking different cells

Reported by: floscher Owned by: team
Priority: major Milestone:
Component: Core Version: tested
Keywords: linux gnome java8 atk Cc:

Description

What steps will reproduce the problem?

  1. Open JOSM and download some OSM data
  2. Select an already existent element with some tags
  3. Select different rows by single-clicking some cells

What is the expected result?

The respective rows highlight, the content of all cells stays the same.

What happens instead?

The contents of the cells change seemingly at random (it's different every time you try it), sometimes only the clicked cell is highlighted instead of the whole row. The cells display strings like {1 = building} or strings that should be displayed in other cells (e.g. wikipedia=access, where the key access displays as the value of the wikipedia tag).

The underlying data doesn't seem to change, only the presentation, because the strange keys/values sometimes change back to the correct keys/values.

See attached video for how that looks.

Please provide any additional information below. Attach a screenshot if possible.

OS: Ubuntu 15.10 64-bit
Java: OpenJDK 8 64-bit
JOSM: r9329 without plugins and empty ~/.josm-folder

Attachments (1)

josm-tageditor-bug.ogv (3.3 MB) - added by floscher 5 years ago.

Change History (4)

Changed 5 years ago by floscher

Attachment: josm-tageditor-bug.ogv added

comment:1 Changed 5 years ago by Don-vip

Keywords: linux gnome java8 atk added

comment:2 Changed 5 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #12022.
You must edit /etc/java-8-openjdk/accessibility.properties and comment out the line assistive_technologies=org.GNOME.Accessibility.AtkWrapper.
See #12332 and #12022

comment:3 Changed 5 years ago by floscher

Thank you! This solved my issues.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.