Modify

Opened 4 years ago

Closed 4 years ago

#12333 closed defect (fixed)

NPE when using Plugin "merge-overlap"

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Plugin merge-overlap Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Two building select
  2. start Plugin "Überlappung vereinigen" Strg-Alt-O (merge-overlap)

What is the expected result?

??

What happens instead?

Error

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-01-06 17:30:31 +0100 (Wed, 06 Jan 2016)
Build-Date:2016-01-06 16:32:31
Revision:9329
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9329 de) Windows XP 32-Bit
Memory Usage: 192 MB / 989 MB (58 MB allocated, but free)
Java version: 1.8.0_45, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugins:
- FixAddresses (31772)
- HouseNumberTaggingTool (31772)
- OpeningHoursEditor (31772)
- RoadSigns (31895)
- buildings_tools (31895)
- livegps (31772)
- measurement (31895)
- merge-overlap (31772)
- print (31895)
- reltoolbox (31895)
- terracer (31895)
- turnlanes (31772)
- turnrestrictions (31895)
- utilsplugin2 (31895)

Last errors/warnings:
- E: java.lang.NullPointerException

java.lang.NullPointerException
	at org.openstreetmap.josm.tools.Utils.exists(Utils.java:103)
	at org.openstreetmap.josm.tools.Utils.forAll(Utils.java:118)
	at org.openstreetmap.josm.gui.conflict.tags.RelationMemberConflictResolverModel.prepareDefaultRelationDecisions(RelationMemberConflictResolverModel.java:202)
	at org.openstreetmap.josm.gui.conflict.tags.CombinePrimitiveResolverDialog.prepareDefaultDecisions(CombinePrimitiveResolverDialog.java:301)
	at mergeoverlap.MergeOverlapAction.combineWaysWorker(MergeOverlapAction.java:556)
	at mergeoverlap.MergeOverlapAction.actionPerformed(MergeOverlapAction.java:214)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.AbstractButton.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by Klumbumbus

Component: CorePlugin merge-overlap
Summary: Plugin "merge-overlap"NPE when using Plugin "merge-overlap"

comment:2 Changed 4 years ago by simon04

Due to the changes in r8871.

Reproduces according to ticket:10680#comment:description.

comment:3 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

Fixed in [o31967:31968].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.