Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12419 closed defect (fixed)

the "add tag window" on 9563 does not work

Reported by: lombardo.geosystems Owned by: kolesar
Priority: major Milestone: 16.02
Component: Core Version:
Keywords: template_report, regression Cc:

Description (last modified by kolesar)

What steps will reproduce the problem?

  1. Add tags to objects to fill recently used tags over the value of properties.recently-added-tags, default value is 5.
  2. Press Add button on properties dialog.

What is the expected result?

See no more recent tags than setting.

What happens instead?

You will see more tags displayed than setting. List can grow up to 30 (maximum value of this setting) that makes dialog unusable.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-01-22 01:47:49 +0100 (Fri, 22 Jan 2016)
Build-Date:2016-01-22 02:34:01
Revision:9563
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9563 it) Linux Ubuntu 14.04.3 LTS
Memory Usage: 709 MB / 1751 MB (109 MB allocated, but free)
Java version: 1.7.0_91-b02, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u91-2.6.3-0ubuntu0.14.04.1
VM arguments: [-Djosm.restart=true, -Djosm.home=/home/riccardo/.josm-latest, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
- ShapeTools (1000)
- buildings_tools (31895)
- osmarender (31772)
- utilsplugin2 (31895)

Attachments (2)

Screenshot from 2016-01-22 05:47:02.png (208.3 KB) - added by lombardo.geosystems 4 years ago.
screenshot
PropertyRecentTagsNumber.patch (782 bytes) - added by kolesar 4 years ago.

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by lombardo.geosystems

screenshot

Changed 4 years ago by kolesar

comment:1 Changed 4 years ago by kolesar

Math.max was used instead of Math.min comparing setting and maximum value. Attached fix.

comment:2 Changed 4 years ago by kolesar

Description: modified (diff)
Owner: changed from team to kolesar
Priority: normalmajor
Status: newassigned

comment:3 Changed 4 years ago by bastiK

Resolution: fixed
Status: assignedclosed

In 9564/josm:

fixed #12419 - the "add tag window" on 9563 shows too many entries (patch by kolesar)

comment:4 Changed 4 years ago by bastiK

Milestone: 16.02

Thanks for the fix!

comment:5 Changed 4 years ago by Klumbumbus

Ticket #12401 has been marked as a duplicate of this ticket.

comment:6 Changed 4 years ago by Klumbumbus

Keywords: regression added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain kolesar.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.