Modify

Opened 6 years ago

Closed 6 years ago

#12406 closed defect (duplicate)

java.awt.AWTError: BoxLayout can't be shared

Reported by: kolesar Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Create a new layer (Ctrl+N)
  2. Draw a way with 3 nodes.
  3. Create a new relation, make new way as a member, save relation.
  4. Split the way at the middle point.
  5. Combine the two ways.

Attached .osm file with steps 1-4 ready. You only need to combine the two ways to reproduce bug.

What is the expected result?

Ways to be combined.

What happens instead?

Exception: java.awt.AWTError: BoxLayout can't be shared

Please provide any additional information below. Attach a screenshot if possible.

Used latest .jar file downloaded from website. Tested version does not have this bug. Started JOSM with empty preferences, no plugins.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-01-20 01:28:07 +0100 (Wed, 20 Jan 2016)
Build-Date:2016-01-20 02:32:45
Revision:9547
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9547 hu) Linux Ubuntu 15.10
Memory Usage: 281 MB / 672 MB (91 MB allocated, but free)
Java version: 1.8.0_66-b17, Oracle Corporation, Java HotSpot(TM) Server VM
Dataset consistency test: No problems found


Last errors/warnings:
- E: java.awt.AWTError: BoxLayout can't be shared

java.awt.AWTError: BoxLayout can't be shared
	at javax.swing.BoxLayout.checkContainer(BoxLayout.java:465)
	at javax.swing.BoxLayout.invalidateLayout(BoxLayout.java:249)
	at javax.swing.BoxLayout.addLayoutComponent(BoxLayout.java:282)
	at java.awt.Container.addImpl(Container.java:1127)
	at java.awt.Container.add(Container.java:417)
	at org.openstreetmap.josm.gui.conflict.tags.RelationMemberConflictResolver.build(RelationMemberConflictResolver.java:67)
	at org.openstreetmap.josm.gui.conflict.tags.RelationMemberConflictResolver.<init>(RelationMemberConflictResolver.java:120)
	at org.openstreetmap.josm.gui.conflict.tags.CombinePrimitiveResolverDialog.buildRelationMemberConflictResolverPanel(CombinePrimitiveResolverDialog.java:185)
	at org.openstreetmap.josm.gui.conflict.tags.CombinePrimitiveResolverDialog.build(CombinePrimitiveResolverDialog.java:173)
	at org.openstreetmap.josm.gui.conflict.tags.CombinePrimitiveResolverDialog.<init>(CombinePrimitiveResolverDialog.java:221)
	at org.openstreetmap.josm.gui.conflict.tags.CombinePrimitiveResolverDialog$1.run(CombinePrimitiveResolverDialog.java:102)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWait(GuiHelper.java:110)
	at org.openstreetmap.josm.gui.conflict.tags.CombinePrimitiveResolverDialog.getInstance(CombinePrimitiveResolverDialog.java:100)
	at org.openstreetmap.josm.gui.conflict.tags.CombinePrimitiveResolverDialog.launchIfNecessary(CombinePrimitiveResolverDialog.java:504)
	at org.openstreetmap.josm.actions.CombineWayAction.combineWaysWorker(CombineWayAction.java:183)
	at org.openstreetmap.josm.actions.CombineWayAction.actionPerformed(CombineWayAction.java:222)
	at javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1663)
	at javax.swing.JComponent.processKeyBinding(JComponent.java:2882)
	at javax.swing.KeyboardManager.fireBinding(KeyboardManager.java:307)
	at javax.swing.KeyboardManager.fireKeyboardAction(KeyboardManager.java:263)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(JComponent.java:2974)
	at javax.swing.JComponent.processKeyBindings(JComponent.java:2966)
	at javax.swing.JComponent.processKeyEvent(JComponent.java:2845)
	at java.awt.Component.processEvent(Component.java:6312)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4891)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4713)
	at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1954)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:806)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:1074)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:945)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:771)
	at java.awt.Component.dispatchEventImpl(Component.java:4762)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Window.dispatchEventImpl(Window.java:2750)
	at java.awt.Component.dispatchEvent(Component.java:4713)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:86)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (1)

BoxLayoutBug.osm (760 bytes) - added by kolesar 6 years ago.

Download all attachments as: .zip

Change History (2)

Changed 6 years ago by kolesar

Attachment: BoxLayoutBug.osm added

comment:1 in reply to:  description Changed 6 years ago by kolesar

Resolution: duplicate
Status: newclosed

Closed as duplicate of #12405.
Update: relation not needed. Combining ways is enough. Duplicate of #12405 that was submitted while I was typing this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.