Modify

Opened 5 years ago

Closed 5 years ago

#12405 closed defect (fixed)

Glue function doesn't work for nodes and ways

Reported by: ViriatoLusitano Owned by: Don-vip
Priority: critical Milestone: 16.02
Component: Core Version: latest
Keywords: regression layout Cc:

Description

What steps will reproduce the problem?

  1. Create way or node

http://i.imgur.com/rPUxCAh.gifv

  1. Try to glue them (I use ctrl shortcut).

http://i.imgur.com/AZ9H7bd.gifv

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-01-20 01:28:07 +0100 (Wed, 20 Jan 2016)
Build-Date:2016-01-20 02:32:45
Revision:9547
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9547 pt) Windows 8.1 64-Bit
Memory Usage: 931 MB / 7282 MB (259 MB allocated, but free)
Java version: 1.8.0_51-b16, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- FastDraw (31895)
- FixAddresses (31772)
- PicLayer (31895)
- SimplifyArea (31895)
- apache-commons (31895)
- buildings_tools (31895)
- download_along (31772)
- editgpx (31772)
- ejml (31895)
- geotools (31895)
- graphview (31895)
- jts (31772)
- log4j (31895)
- measurement (31895)
- merge-overlap (31967)
- opendata (31937)
- pdfimport (31895)
- reverter (32005)
- tagging-preset-tester (31895)
- terracer (31895)
- turnrestrictions (31895)
- undelete (31895)
- utilsplugin2 (31895)

Last errors/warnings:
- W: Unable to use English input method
- E: java.awt.AWTError: BoxLayout can't be shared
- E: java.awt.AWTError: BoxLayout can't be shared
- E: java.awt.AWTError: BoxLayout can't be shared
- E: java.awt.AWTError: BoxLayout can't be shared

java.awt.AWTError: BoxLayout can't be shared
	at javax.swing.BoxLayout.checkContainer(Unknown Source)
	at javax.swing.BoxLayout.invalidateLayout(Unknown Source)
	at javax.swing.BoxLayout.addLayoutComponent(Unknown Source)
	at java.awt.Container.addImpl(Unknown Source)
	at java.awt.Container.add(Unknown Source)
	at org.openstreetmap.josm.gui.conflict.tags.RelationMemberConflictResolver.build(RelationMemberConflictResolver.java:67)
	at org.openstreetmap.josm.gui.conflict.tags.RelationMemberConflictResolver.<init>(RelationMemberConflictResolver.java:120)
	at org.openstreetmap.josm.gui.conflict.tags.CombinePrimitiveResolverDialog.buildRelationMemberConflictResolverPanel(CombinePrimitiveResolverDialog.java:185)
	at org.openstreetmap.josm.gui.conflict.tags.CombinePrimitiveResolverDialog.build(CombinePrimitiveResolverDialog.java:173)
	at org.openstreetmap.josm.gui.conflict.tags.CombinePrimitiveResolverDialog.<init>(CombinePrimitiveResolverDialog.java:221)
	at org.openstreetmap.josm.gui.conflict.tags.CombinePrimitiveResolverDialog$1.run(CombinePrimitiveResolverDialog.java:102)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWait(GuiHelper.java:110)
	at org.openstreetmap.josm.gui.conflict.tags.CombinePrimitiveResolverDialog.getInstance(CombinePrimitiveResolverDialog.java:100)
	at org.openstreetmap.josm.gui.conflict.tags.CombinePrimitiveResolverDialog.launchIfNecessary(CombinePrimitiveResolverDialog.java:504)
	at org.openstreetmap.josm.actions.MergeNodesAction.mergeNodes(MergeNodesAction.java:340)
	at org.openstreetmap.josm.actions.MergeNodesAction.doMergeNodes(MergeNodesAction.java:270)
	at org.openstreetmap.josm.actions.mapmode.SelectAction.mergeNodes(SelectAction.java:932)
	at org.openstreetmap.josm.actions.mapmode.SelectAction.mergePrims(SelectAction.java:920)
	at org.openstreetmap.josm.actions.mapmode.SelectAction.confirmOrUndoMovement(SelectAction.java:855)
	at org.openstreetmap.josm.actions.mapmode.SelectAction.mouseReleased(SelectAction.java:628)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by kolesar

Ticket #12406 has been marked as a duplicate of this ticket.

comment:2 Changed 5 years ago by Don-vip

Keywords: regression layout added
Milestone: 16.02
Owner: changed from team to Don-vip
Status: newassigned

comment:3 Changed 5 years ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 9548/josm:

fix #12405 - wrong JPanel initialization (regression from r9543)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.