Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#12336 closed defect (worksforme)

Can't zoom in beyond 22m on Bing imagery

Reported by: Polyglot Owned by: Polyglot
Priority: normal Milestone:
Component: Core imagery Version:
Keywords: template_report bing Cc:

Description

What steps will reproduce the problem?

  1. Zoom in beyond 22m

2.

What is the expected result?

Keep seeing imagery, it starts to be pixelated but is still useful to mark buildings

What happens instead?

Icons of a camera barred with a diagonal line and a circle around them

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-01-08 10:43:21 +0100 (Fri, 08 Jan 2016)
Build-Date:2016-01-09 02:34:54
Revision:9345
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9345 en) Windows 7 64-Bit
Memory Usage: 566 MB / 1111 MB (133 MB allocated, but free)
Java version: 1.8.0_66-b18, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- Mapillary (31895)
- OSMRecPlugin (31772)
- OpeningHoursEditor (31772)
- PicLayer (31895)
- RoadSigns (31895)
- apache-commons (31895)
- apache-http (31895)
- buildings_tools (31895)
- conflation (0.1.9)
- contourmerge (1014)
- dataimport (31772)
- ejml (31895)
- geotools (31895)
- imagery_offset_db (31895)
- jts (31772)
- kendzi3d-jogl (41)
- log4j (31895)
- measurement (31895)
- merge-overlap (31772)
- opendata (31937)
- photo_geotagging (31895)
- public_transport_layer (31932)
- scripting (30722)
- splinex (31895)
- tag2link (31910)
- terracer (31895)
- todo (29154)
- turnrestrictions (31895)
- undelete (31895)
- utilsplugin2 (31895)
- wikipedia (31917)

Last errors/warnings:
- W:  Roads that cannot be completed: Could not get presets icon presets/way_tertiary.png
- E: Failed to locate image 'presets/way_unclassified.png'
- W:  Unfinished secondary roads: Could not get presets icon presets/way_unclassified.png
- E: Failed to locate image 'presets/places.png'
- W:  Place and residential area: Could not get presets icon presets/places.png

Attachments (0)

Change History (15)

comment:1 Changed 6 years ago by Polyglot

This started happening with the Latest from yesterday. In Europe the cutoff point is between 10-14m.

comment:2 Changed 6 years ago by Klumbumbus

Please give a link to the location where this happens.

comment:3 Changed 6 years ago by wiktorn

I tried in few places (Warsaw, Berlin, London, Paris) and tiles are available up to zoom level 19-20 (depending on city). And after zooming closer JOSM properly detects that there are no tiles below and I do not get the icon with barred camera. Please, share a place, where you do observe this problem.

comment:4 Changed 6 years ago by stoecker

Owner: changed from team to Polyglot
Status: newneedinfo

comment:5 Changed 6 years ago by Polyglot

I created a screencast of a few minutes, zooming in on regions in Africa. I first noticed it when working in Swaziland.

Then I went to some European capitals. Before I never saw that camera icon.

http://www.twitch.tv/polyglot_openstreetmap/v/34887741

I download the latest josm-latest and include a new report

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-01-08 10:43:21 +0100 (Fri, 08 Jan 2016)
Build-Date:2016-01-09 02:34:54
Revision:9345
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9345 en) Windows 7 64-Bit
Memory Usage: 590 MB / 1111 MB (277 MB allocated, but free)
Java version: 1.8.0_66-b18, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- Mapillary (31895)
- OSMRecPlugin (31772)
- OpeningHoursEditor (31772)
- PicLayer (31895)
- RoadSigns (31895)
- apache-commons (31895)
- apache-http (31895)
- buildings_tools (31895)
- conflation (0.1.9)
- contourmerge (1014)
- dataimport (31772)
- ejml (31895)
- geotools (31895)
- imagery_offset_db (31895)
- jts (31772)
- kendzi3d-jogl (41)
- log4j (31895)
- measurement (31895)
- merge-overlap (31772)
- opendata (31937)
- photo_geotagging (31895)
- public_transport_layer (31932)
- scripting (30722)
- splinex (31895)
- tag2link (31910)
- terracer (31895)
- todo (29154)
- turnrestrictions (31895)
- undelete (31895)
- utilsplugin2 (31895)
- wikipedia (31917)

Last errors/warnings:
- W:  Roads that cannot be completed: Could not get presets icon presets/way_tertiary.png
- E: Failed to locate image 'presets/way_unclassified.png'
- W:  Unfinished secondary roads: Could not get presets icon presets/way_unclassified.png
- E: Failed to locate image 'presets/places.png'
- W:  Place and residential area: Could not get presets icon presets/places.png

comment:6 Changed 6 years ago by wiktorn

Strange. I can't reproduce this (at least - in Lesotho - https://www.openstreetmap.org/#map=22/50.879264657186624/4.702105554747403)

Can you please provide the screenshot, what do you see, if you click right mouse button on such camera icon, and chose "Show tile info" from the menu?

There two things that might went wrong:

  • your imagery preferences for Bing somehow lost information, how to identify missing tiles, then refreshing imagery preferences should help
  • you experience this only in locations that you visited before, with version before [9228], and you have in JOSM cache tiles, which improperly reports as proper tiles (due to a bug in Java). Then flushing the tile cache should help

comment:7 Changed 6 years ago by Klumbumbus

Offtopic:

Last errors/warnings:

  • W: Roads that cannot be completed: Could not get presets icon presets/way_tertiary.png
  • E: Failed to locate image 'presets/way_unclassified.png'
  • W: Unfinished secondary roads: Could not get presets icon presets/way_unclassified.png
  • E: Failed to locate image 'presets/places.png'
  • W: Place and residential area: Could not get presets icon presets/places.png

I reported the missing preset icons here https://github.com/hotosm/osm-tasking-manager2/issues/730

comment:8 Changed 6 years ago by Polyglot

Thanks for looking into the missing icons.

I created a new screencast. The dates reported look odd, 2016.

http://www.twitch.tv/polyglot_openstreetmap/v/34905433

I have it everywhere I tried. I'm sure I didn't map in Germany, Amsterdam or London recently, but I tried flushing the cache. How do I refresh imagery preferences? I'm going to try and go back to the latest josm-tested.jar to see what that does.

Jo

comment:9 Changed 6 years ago by Don-vip

Component: CoreCore imagery
Keywords: bing added

comment:10 in reply to:  8 Changed 6 years ago by wiktorn

Replying to Polyglot:

I have it everywhere I tried. I'm sure I didn't map in Germany, Amsterdam or London recently, but I tried flushing the cache. How do I refresh imagery preferences? I'm going to try and go back to the latest josm-tested.jar to see what that does.

If you open Imagery Preferences, there is on the right, below the map, refresh button. Click on it.

Do you by any chance run your traffic through some proxy? Because it looks like someone is stripping down X-VE-Tile-Info HTTP header from server.

comment:11 Changed 6 years ago by Polyglot

My previous message didn't go through apparently. Marked as spam and I noticed it too late.

Anyway, I've been trying with different internet providers in the mean time, so it must be my Windows installation that causes this somehow.

Since I seem to be the only one, I guess it's not overly important. It means I'm back to mapping in Belgium with different imagery and not validating HOT tasks anymore.

When I reboot in Linux, I'll let you know if it were to happen there as well.

Cheers and thank you for all the great work on my favourite editor!

Jo

comment:12 Changed 6 years ago by wiktorn

The only thing that I can think of that you may try, is just to start with empty preferences.

Rename the folder: %APPDATA%/JOSM to %APPDATA%/JOSM.old and start JOSM. If the problem persists, then I'm out of ideas. If it works properly, then it means that something in your settings was wrong. Investigation of your preferences.xml could lead to the source of the problem.

comment:13 Changed 6 years ago by Polyglot

That worked indeed. Is somebody interested in that preferences.xml file for a post mortem?

I seized the opportunity to create some screencasts about how to set up JOSM when starting fresh and some example mapping in Swaziland and near the North Pole (Svalbard) with some extraordinary imagery.

http://www.openstreetmap.org/user/Polyglot/diary/37764

Jo

comment:14 Changed 6 years ago by Polyglot

Resolution: worksforme
Status: needinfoclosed

comment:15 in reply to:  13 Changed 6 years ago by wiktorn

Replying to Polyglot:

That worked indeed. Is somebody interested in that preferences.xml file for a post mortem?

I can take a look during the weekend and investigate it further.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Polyglot.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.