Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#12321 closed defect (fixed)

JOSM SVN compiled with openjdk 7 fails to start

Reported by: malenki Owned by: team
Priority: normal Milestone: 16.02
Component: Core Version:
Keywords: template_report Cc: bastiK

Description

What steps will reproduce the problem?

  1. have OpenJDK 7 as default
  2. compile JOSM from svn (I do it with this script)
  3. start JOSM

What is the expected result?

JOSM starts

What happens instead?

JOSM reports an error (look at "additional information) and gets stuck at

$ java -jar /home/nadar/source/josm/dist/josm-custom.jar
INFO: Detected useable IPv6 network, prefering IPv6 over IPv4.
ERROR: java.lang.AssertionError: Error: Unknown projection code
java.lang.AssertionError: Error: Unknown projection code
	at org.openstreetmap.josm.gui.preferences.projection.AbstractProjectionChoice.getProjection(AbstractProjectionChoice.java:64)
	at org.openstreetmap.josm.gui.preferences.projection.ProjectionPreference.setProjection(ProjectionPreference.java:419)
	at org.openstreetmap.josm.gui.preferences.projection.ProjectionPreference.setProjection(ProjectionPreference.java:398)
	at org.openstreetmap.josm.Main.preConstructorInit(Main.java:930)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:457)
INFO: GET https://josm.openstreetmap.de/wiki/TestedVersion?format=txt -> 200

Please provide any additional information below. Attach a screenshot if possible.

Java used:
java version "1.7.0_91"
OpenJDK Runtime Environment (IcedTea 2.6.3) (7u91-2.6.3-3)
OpenJDK 64-Bit Server VM (build 24.91-b01, mixed mode)

JOSM used:
r9353, blank ~/.josm

With OpenJDK 8 there are no problems.
openjdk version "1.8.0_72-internal"
OpenJDK Runtime Environment (build 1.8.0_72-internal-b05)
OpenJDK 64-Bit Server VM (build 25.72-b05, mixed mode)

Build-Date:2016-01-09 16:41:43
Revision:9353
Is-Local-Build:true

Identification: JOSM/1.5 (9353 SVN de) Linux Debian GNU/Linux unstable (sid)
Memory Usage: 123 MB / 1102 MB (92 MB allocated, but free)
Java version: 1.7.0_91-b02, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u91-2.6.3-3
VM arguments: [-Dsun.java2d.opengl=false]


Last errors/warnings:
- E: java.lang.AssertionError: Error: Unknown projection code

java.lang.AssertionError: Error: Unknown projection code
	at org.openstreetmap.josm.gui.preferences.projection.AbstractProjectionChoice.getProjection(AbstractProjectionChoice.java:64)
	at org.openstreetmap.josm.gui.preferences.projection.ProjectionPreference.setProjection(ProjectionPreference.java:419)
	at org.openstreetmap.josm.gui.preferences.projection.ProjectionPreference.setProjection(ProjectionPreference.java:398)
	at org.openstreetmap.josm.Main.preConstructorInit(Main.java:930)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:457)

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by simon04

Cc: bastiK added

Since r9133, JOSM can only be compiled in the repository root directory.

comment:2 Changed 3 years ago by simon04

Resolution: fixed
Status: newclosed

In 9357/josm:

fix #12321 - Allow JOSM to be compiled outside of repository root directory

Regression of r9133.

comment:3 Changed 3 years ago by simon04

Milestone: 16.02

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.