Modify

Opened 4 years ago

Closed 4 years ago

#12305 closed defect (fixed)

"Center view" button greyed out in Geotagged Images pane

Reported by: bartosomail@… Owned by: holgermappt
Priority: normal Milestone:
Component: Plugin photoadjust Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. It happened a few times, always while I was working at image postition adjusting. I still haven't find a way to deliberately reproduce the problem.

What is the expected result?

the "Center view" button should never become greyed out

What happens instead?

I erratically find myself with the "Center view" button disabled (greyed out) in the Geotagged Images pane.

Please provide any additional information below. Attach a screenshot if possible.

Restarting JOSM makes the button available again.
I suspect the plugin photoadjust might be involved, because i first noticed the issue after I updated it to Version 31953.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-01-06 17:30:31 +0100 (Wed, 06 Jan 2016)
Build-Date:2016-01-06 16:32:31
Revision:9329
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9329 en) Windows 7 64-Bit
Memory Usage: 307 MB / 989 MB (168 MB allocated, but free)
Java version: 1.8.0_66, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugins:
- ImportImagePlugin (31772)
- Mapillary (31895)
- OpeningHoursEditor (31772)
- PicLayer (31895)
- SimplifyArea (31895)
- apache-commons (31895)
- apache-http (31895)
- buildings_tools (31895)
- download_along (31772)
- editgpx (31772)
- ejml (31895)
- geotools (31895)
- gpxfilter (31772)
- jts (31772)
- log4j (31895)
- measurement (31895)
- merge-overlap (31772)
- photo_geotagging (31895)
- photoadjust (31953)
- public_transport (31895)
- rasterfilters (31895)
- reltoolbox (31895)
- reverter (31897)
- routing (31772)
- tag2link (31910)
- terracer (31895)
- todo (29154)
- undelete (31895)
- utilsplugin2 (31895)
- waydownloader (31772)
- wikipedia (31917)

Last errors/warnings:
- W: Failed to parse Mappaint styles from 'D:\OSM\JOSM\Josm personalization\Albertstyles.xml'. Error was: [304:7] The end-tag for element type "rule" must end with a '>' delimiter.
- E: org.xml.sax.SAXParseException: The end-tag for element type "rule" must end with a '>' delimiter.
- W: Initializing map style D:\OSM\JOSM\Josm personalization\Albertstyles.xml completed in 374 ms (1 errors)
- W: PluginException: Invalid jar file 'C:\Users\Yoghi\AppData\Roaming\JOSM\plugins\TombPlugin.jar.new'
- W: Failed to scan file 'TombPlugin.jar.new' for plugin information. Skipping.

Attachments (0)

Change History (5)

comment:1 Changed 4 years ago by holgermappt

This happens when a data layer is active and the PhotoAdjustMapMode (image with arrows in the left pane) is active. It works if a geo image layer is active. The problem is that no mouseReleased() is called while the data layer is active. The according MouseAdapter was added with Main.map.mapView.addMouseListener(mouseAdapter);. I get the mouseReleased() if a geo image layer is active. Is someone reading this who has an idea why mousePressed() is called but mouseReleased() not?

Last edited 4 years ago by holgermappt (previous) (diff)

comment:2 Changed 4 years ago by holgermappt

Problem found: mouseReleased() is missing in PhotoAdjustMapMode. I will fix it tomorrow.

comment:3 Changed 4 years ago by holgermappt

Status: newassigned

I added the missing mouseReleased() in [o31962]. Please try plugin version 31963.

The Center view button is disabled (grayed out) while a photo is moved. This is necessary to move a photo if the center view is active, see #11908. The Center view button is enabled again if the mouse button is released.

comment:4 Changed 4 years ago by bartosomail@…

Ah, now I understand why I couldn't replicate: I always used the shift+click for image repositioning, but I must have occasionally dragged a picture unintentionally. Working fine now, thanks for the fix!

comment:5 Changed 4 years ago by bartosomail@…

Resolution: fixed
Status: assignedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain holgermappt.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.