Modify

Opened 4 years ago

Closed 4 years ago

#12280 closed defect (fixed)

Add files saved, to list of recent files

Reported by: ar2988-os@… Owned by: team
Priority: normal Milestone: 16.01
Component: Core Version: tested
Keywords: Cc:

Description

I propose that when you save a file of OSM data, it is added to the list of recent files.

Attachments (0)

Change History (5)

comment:1 Changed 4 years ago by simon04

Owner: changed from team to ar2988-os@…
Status: newneedinfo

Isn't that part of JOSM since #6728? If not, please provide more details (see newticket).

comment:2 in reply to:  1 Changed 4 years ago by ar2988-os@…

Replying to simon04:

OK, it works if you use Save As... from the file menu but it has never worked from the context menu in the Layers window (which is what I have always used).
It is analogous to the bug of getting two instances of the preferences dialog if you use the keyboard shortcut (command-,) but only one instance if you use the toolbar button.

What steps will reproduce the problem?

  1. Launch JOSM
  2. Download some data from the OSM server
  3. Save the layer as foo.osm using the context menu in the "Layers" window
  4. Quit JOSM
  5. Relaunch JOSM
  6. Look for foo.osm in the list of recent files

What is the expected result?

The file is in the list.

What happens instead?

The file is not in the list.

Please provide any additional information below. Attach a screenshot if possible.

This happens whether you use the native file dialogs or the Java ones. I use the Java ones because the native ones do not work well on OS X.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2015-12-31 13:54:58 +0100 (Thu, 31 Dec 2015)
Build-Date:2015-12-31 12:57:00
Revision:9229
Relative:URL: /trunk

Identification: JOSM/1.5 (9229 en) Mac OS X 10.9.5
Memory Usage: 212 MB / 3641 MB (88 MB allocated, but free)
Java version: 1.8.0_66, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM

comment:3 Changed 4 years ago by Don-vip

Owner: changed from ar2988-os@… to team
Status: needinfonew

comment:4 Changed 4 years ago by Don-vip

Milestone: 16.01
Type: enhancementdefect

confirmed

comment:5 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

In 9303/josm:

fix #12280 - Save as in layer list context menu does not add to list of recent files

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.