Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12259 closed defect (fixed)

Colors in relation editor (using dark system theme)

Reported by: arvid.nr+josm@… Owned by: team
Priority: normal Milestone: 15.12
Component: Core Version:
Keywords: template_report color relation editor Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Use Linux
  2. Set JOSM to use GTK+ "Look and feel" (Preferences -> Display Settings -> Look and Feel)
  3. Use a GTK+ theme with light text and dark background.
  4. Open relation editor for a relation with at least one member in it
  5. In the main view, select a member of the relation.
  6. Observe light on light colours in relation editor.


I have not been able to figure out which colour (if any) this one is in the settings. At least none of the entries that read like they should be related has any effect on this.

What is the expected result?

Something readable? Or at least the ability to modify the settings so that it is readable (I'm perfectly OK with messing with settings to make my light on dark theme work, most people don't use such themes, outside of terminal emulators perhaps, but I find it much more restful for the eyes when working for long periods in front of a monitor).

What happens instead?

White on light green I think?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2015-12-30 18:40:01 +0100 (Wed, 30 Dec 2015)
Build-Date:2015-12-30 17:42:02
Revision:9222
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9222 en) Linux Debian GNU/Linux 8.2 (jessie)
Memory Usage: 1697 MB / 3568 MB (1025 MB allocated, but free)
Java version: 1.8.0_66-internal, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Djosm.restart=true, -Djosm.home=/home/arvid/.josm-latest, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
- AddrInterpolation (31772)
- CommandLine (31869)
- HouseNumberTaggingTool (31772)
- Mapillary (31884)
- OpeningHoursEditor (31772)
- PicLayer (31772)
- RoadSigns (31772)
- alignways (31772)
- apache-commons (31772)
- apache-http (31875)
- buildings_tools (31772)
- download_along (31772)
- ejml (31772)
- ext_tools (31772)
- geotools (31774)
- gpsblam (31772)
- gpxfilter (31772)
- graphview (31772)
- imagery_offset_db (31772)
- josm-plugin-opengl (1440156917)
- jts (31772)
- log4j (31879)
- measurement (31772)
- opendata (31772)
- rasterfilters (31772)
- routing (31772)
- terracer (31772)
- turnlanes (31772)
- turnrestrictions (31772)
- utilsplugin2 (31772)
- waydownloader (31772)

Attachments (2)

relation_editor.png (1.5 MB) - added by arvid.nr+josm@… 4 years ago.
bus.png (5.4 KB) - added by Klumbumbus 4 years ago.

Download all attachments as: .zip

Change History (13)

Changed 4 years ago by arvid.nr+josm@…

Attachment: relation_editor.png added

comment:1 Changed 4 years ago by arvid.nr+josm@…

I just noticed the same issue in the node history view (Ctrl-H), I have not yet checked if that is configurable, it sounds like "Conflict background" could be related to that? Though the actual conflict resolving window works, since it uses the conflict foreground colour from the preferences.

comment:2 Changed 4 years ago by Don-vip

Description: modified (diff)
Keywords: color relation editor added
Milestone: 15.12
Summary: Colors in releation editor (using dark system theme)Colors in relation editor (using dark system theme)

comment:3 Changed 4 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 9223/josm:

fix #12259 - adjust colors contrast in relation editor and history dialog

comment:4 Changed 4 years ago by Don-vip

r9223 is the new latest version, can you please check if everything's okay?

comment:5 Changed 4 years ago by anonymous

Seems to work for those two cases. Hopefully I won't discover any more.

Also, the changeset was an interesting read, always makes me happy when there is a SO reference in there for further reading about the algorithm. (I'm a programmer myself, not Java though, embedded hard real time control systems, mostly C)

Changed 4 years ago by Klumbumbus

Attachment: bus.png added

comment:6 Changed 4 years ago by Klumbumbus

Hm... While the car driver is an exemplary driver, the bus driver forgot to use the headlights, when driving in dark theme. ;)


comment:7 Changed 4 years ago by arvid.nr+josm@…

Heh, that is true. Not an issue for me personally (I follow the "everything should be a shortcut"-school of thinking). But I think the icons is a separate issue perhaps. I looked in "customize toolbar" and there are several icons that are just a black outline or is otherwise very hard to see on a dark background. That seems like a lot of work to fix though.

comment:8 Changed 4 years ago by arvid.nr+josm@…

How stupid of me.... The issue is worse in the "customize toolbar" dialog, since that is a darker grey background in my case than the actual toolbar itself uses. Though there are still some icons that are hard to see on the actual grey of the toolbar I use. Still, this seems really complicated to solve.

comment:9 Changed 4 years ago by zermes

I was testing the new icons in black and white, but only the ones used on nodes. It seems I have to test them all now. I will see if I can get that Debian with that theme. By the way it's a nice theme useful in dark ambient. Thanks for pointing this problem.

comment:10 Changed 4 years ago by anonymous

Getting that specific theme will be hard, I made the colour scheme myself based on the Monokai colour scheme from the text editor Sublime.

I'm using the MATE desktop environment (yeah everything after Gnome 2 is bad IMO), and the theme is based on the TraditionalOk theme (what a terrible theme name by the way) and then switching around the colours.

comment:11 in reply to:  10 Changed 4 years ago by zermes

Replying to anonymous:

Getting that specific theme will be hard, I made the colour scheme myself based on the Monokai colour scheme from the text editor Sublime.

I'm using the MATE desktop environment (yeah everything after Gnome 2 is bad IMO), and the theme is based on the TraditionalOk theme (what a terrible theme name by the way) and then switching around the colours.

I'm not a JOSM developer, I'm only making some icons for it. I didn't tried Debian (too many gigabytes and probably in the end I would have problems installing it). I've tried Ubuntu. But I could't install the latest Java (those Oracle instructions are really bad for linux newbies). I couldn't figure out how to install the latest JOSM too from this site. Ubuntu Software center has only the 8159 version.

So I gave up and remembered I could personalize Windows theme (forget windows themes, even those in Microsoft website, they don't have a dark theme, and windows only have some pure black and white from the 1990 era) and got one very similar to that one. Now I can test them. Of course I can simulate the icons in Inkscape in grey background but I prefer to test them also in JOSM menus.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.