Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12257 closed defect (fixed)

Caret in edit fields is dark when using a dark system theme

Reported by: arvid.nr+josm@… Owned by: team
Priority: normal Milestone: 15.12
Component: Core Version:
Keywords: template_report text caret color Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

Along the lines of bug 12256, I noticed that the text insertion marker (I don't know the "official" name of this feature, so please refer to the screenshot below if you don't see what I mean) in various input fields are black.

  1. Use Linux
  2. Set JOSM to use GTK+ "Look and feel" (Preferences -> Display Settings -> Look and Feel)
  3. Use a GTK+ theme with light text and dark background.
  4. Click in the middle of any edit field (for example, in the "Change value?" dialog for tags).
  5. Observe how unlike any other GTK+ or Qt programs at least, the text insertion marker is black (on dark grey background). Most other programs that I tried use a sensible light on dark instead, possibly just using the inverse colour or the text colour?

Near invisible text insertion marker

What is the expected result?

There should be an option in the settings to manually set the colour of the text insertion marker, or it should just work (like it does in other programs). I don't know if other programs simply use the text colour for this, or if they use the inverse background colour.

What happens instead?

The text insert "marker" is black, as shown in the screenshot (I added a red arrow pointing to it since it was so hard to see). It is between the g and the e in the Value field.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2015-12-30 03:21:52 +0100 (Wed, 30 Dec 2015)
Build-Date:2015-12-30 02:34:43
Revision:9220
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9220 en) Linux Debian GNU/Linux 8.2 (jessie)
Memory Usage: 1064 MB / 3568 MB (588 MB allocated, but free)
Java version: 1.8.0_66-internal, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Djosm.restart=true, -Djosm.home=/home/arvid/.josm-latest, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
- AddrInterpolation (31772)
- CommandLine (31869)
- HouseNumberTaggingTool (31772)
- Mapillary (31884)
- OpeningHoursEditor (31772)
- PicLayer (31772)
- RoadSigns (31772)
- alignways (31772)
- apache-commons (31772)
- apache-http (31875)
- buildings_tools (31772)
- download_along (31772)
- ejml (31772)
- ext_tools (31772)
- geotools (31774)
- gpsblam (31772)
- gpxfilter (31772)
- graphview (31772)
- imagery_offset_db (31772)
- josm-plugin-opengl (1440156917)
- jts (31772)
- log4j (31879)
- measurement (31772)
- opendata (31772)
- rasterfilters (31772)
- routing (31772)
- terracer (31772)
- turnlanes (31772)
- turnrestrictions (31772)
- utilsplugin2 (31772)
- waydownloader (31772)

Last errors/warnings:
- E: java.io.IOException: Server returned HTTP response code: 504 for URL: https://a.mapillary.com/v2/search/im/or/?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&min_lon=15.207668&max_lat=59.273803&max_lon=15.211127&limit=20&page=22&min_lat=59.272660
- E: java.io.IOException: Server returned HTTP response code: 504 for URL: https://a.mapillary.com/v2/search/im/or/?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&min_lon=15.209538&max_lat=59.276012&max_lon=15.223665&limit=20&page=20&min_lat=59.271345
- E: java.io.IOException: Server returned HTTP response code: 504 for URL: https://a.mapillary.com/v2/search/im/or/?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&min_lon=15.207668&max_lat=59.273803&max_lon=15.211127&limit=20&page=23&min_lat=59.272660
- E: java.io.IOException: Server returned HTTP response code: 504 for URL: https://a.mapillary.com/v2/search/im/or/?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&min_lon=15.207668&max_lat=59.273803&max_lon=15.211127&limit=20&page=21&min_lat=59.272660
- E: java.io.IOException: Server returned HTTP response code: 504 for URL: https://a.mapillary.com/v2/search/im/or/?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&min_lon=15.209538&max_lat=59.276012&max_lon=15.223665&limit=20&page=19&min_lat=59.271345

Attachments (1)

text_insertion_cursor.png (17.0 KB) - added by arvid.nr+josm@… 4 years ago.
Near invisible text insertion marker

Download all attachments as: .zip

Change History (11)

Changed 4 years ago by arvid.nr+josm@…

Attachment: text_insertion_cursor.png added

Near invisible text insertion marker

comment:1 Changed 4 years ago by arvid.nr+josm@…

I just now noticed that that the near invisible marker is only near invisible on my expensive colour calibrated IPS display. On my cheap non-calibrated laptop display it is quite visible. Still, black on dark grey is obviously not optimal.

comment:2 Changed 4 years ago by Don-vip

Description: modified (diff)

comment:3 Changed 4 years ago by Don-vip

It should be the text color by default, not black. This field has some particularities, is this similar with a simpler one like tag filter edit field at the top of tags/memberships dialog? (just above tag table)

comment:4 Changed 4 years ago by anonymous

It is the same with that input indeed. Same for the "search menu items" at the top of JOSM as well for example. In fact I can't find any input field in JOSM where the input marker is not black.

comment:5 Changed 4 years ago by Don-vip

Keywords: text caret color added
Milestone: 15.12
Summary: Insert cursor in edit fields is dark when using a dark system themeCaret in edit fields is dark when using a dark system theme

OK thanks. It's called caret by the way: https://en.wikipedia.org/wiki/Caret_navigation

comment:6 Changed 4 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 9222/josm:

fix #12257 - Ensures caret color is the same than text foreground color

comment:7 Changed 4 years ago by Don-vip

I have published r9222 as new latest, can you please tell me if it works as expected now?

comment:8 Changed 4 years ago by anonymous

The easiest way for me is waiting for https://josm.openstreetmap.de/apt (alldist) to update (since I run Debian), do you have any idea how often it updates? Otherwise I guess I can run it manually.

comment:9 Changed 4 years ago by anonymous

Apparently it updated slightly after my comment above. Yes it works.

comment:10 Changed 4 years ago by Don-vip

Great! Thanks for your feedback. Don't hesitate to create new tickets if you find more UI problems related to the dark look and feel, this is really appreciated.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.