Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#12216 closed defect (othersoftware)

Overpass API import

Reported by: Martin_Borsje Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report overpass timeout Cc:

Description (last modified by simon04)

What steps will reproduce the problem?

  1. Build query. e.g user:"gerrit_dankelman"
  2. Show small map tile with data of user in it

Generated code:

[timeout:25];
// gather results
(
  // query part for: “user:gerrit_dankelman”
  node(user:"gerrit_dankelman");
  way(user:"gerrit_dankelman");
  relation(user:"gerrit_dankelman");
);
// print results
out meta;
>;
out meta;
  1. run 'download

What is the expected result?

user data within the bbox

What happens instead?

starts downloading worldwide data of user (I guess) and times out
Message: Failed to download data. Its format is either unsupported, ill-formed, and/or inconsistent. Details (untranslated): runtime error: Query timed out in "print" at line 12 after 34 seconds.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2015-11-24 00:04:12 +0100 (Tue, 24 Nov 2015)
Build-Date:2015-11-23 23:14:21
Revision:9060
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9060 en) Windows 10 64-Bit
Memory Usage: 211 MB / 989 MB (43 MB allocated, but free)
Java version: 1.8.0_66, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugins:
- FastDraw (31772)
- ImportImagePlugin (31772)
- PicLayer (31772)
- apache-commons (31772)
- buildings_tools (31772)
- contourmerge (1014)
- ejml (31772)
- geotools (31774)
- jts (31772)
- log4j (31772)
- merge-overlap (31772)
- opendata (31772)
- reltoolbox (31772)
- reverter (31772)
- tageditor (31772)
- turnrestrictions (31772)
- utilsplugin2 (31772)
- wikipedia (31772)

Last errors/warnings:
- E: Failed to locate image 'images/wfs.png'
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<line 5: parse error: Unknown query clause>, Error Body=<<?xml version="1.0" encoding="UTF-8"?>
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<line 5: parse error: Unknown query clause>, Error Body=<<?xml version="1.0" encoding="UTF-8"?>
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<line 5: static error: Exactly one of the two attributes "name" and "uid" must be set.>, Error Body=<<?xml version="1.0" encoding="UTF-8"?>

Attachments (0)

Change History (9)

comment:1 Changed 7 years ago by Don-vip

Keywords: overpass timeout added

comment:2 Changed 7 years ago by simon04

Description: modified (diff)
Resolution: othersoftware
Status: newclosed

This query also fails using Overpass Turbo (http://overpass-turbo.eu/s/dxO). Seems to be an issue of the Overpass API – please report at https://github.com/drolbr/Overpass-API

comment:3 Changed 7 years ago by anonymous

In my case the query did not fail in Overpass turbo.

/*
This has been generated by the overpass-turbo wizard.
The original search was:
“user:"Martin Borsje"”
*/
[out:json][timeout:25];
// gather results
(
  // query part for: “user:"Martin Borsje"”
  node(user:"Martin Borsje")({{bbox}});
  way(user:"Martin Borsje")({{bbox}});
  relation(user:"Martin Borsje")({{bbox}});
);
// print results
out body;
>;
out skel qt;
Last edited 7 years ago by simon04 (previous) (diff)

comment:4 Changed 7 years ago by simon04

Resolution: othersoftware
Status: closedreopened

comment:5 Changed 7 years ago by simon04

Resolution: othersoftware
Status: reopenedclosed

The timeout is parsed since r9308 (you can download it from https://josm.openstreetmap.de/jenkins/job/JOSM/590/jdk=JDK7/ for testing).

The other thing is that Overpass does not return a <bounds> element, thus it looks like the whole planet is queries when it is not. I created an issue on GitHub: https://github.com/drolbr/Overpass-API/issues/251

comment:6 Changed 7 years ago by Martin_Borsje

Simon: thanks, but it is still strange to me that when I use the Overpass Turbo site I can download data from me as user (of course in an area where I have been editing) and can export that to JOSM successfully, while not directly importing from JOSM through API.

I used combinations as user:"Martin Borsje", user="Martin Borsje", "user"=etc.

comment:7 Changed 7 years ago by stoecker

Maybe the user query is restricted to a login or openly available logs?

comment:8 Changed 7 years ago by simon04

Sending http://overpass-turbo.eu/s/dxY to JOSM via remote control works for me (using ⩾r9308). One has to select an area in Overpass Turbo that will contain data.

Overpass API has no login, authentication mechanism

comment:9 Changed 7 years ago by simon04

https://github.com/drolbr/Overpass-API/issues/251 has been closed; we await a rework of the Overpass Turbo wizard which will include a global {{bbox}} statement, and thus, the Overpass API returns download bounds.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.