Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12126 closed defect (duplicate)

Values/tags changing while moving mouse on list

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report linux debian ubuntu Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Open JOSM
  2. Load data
  3. Edit tag (i.e. addr:housenumber)
  4. Open list and move cursor up and down
  5. Screenshot no. 1

Screenshot no.1

  1. Select some value and OK
  2. Randomly click in keys/values in tags window.
  3. Screenshot no. 2

Screenshot no.2

original tags:

Screenshot no.2 original tags

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2015-11-19 22:39:47 +0100 (Thu, 19 Nov 2015)
Build-Date:2015-11-20 02:32:35
Revision:9032
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9032 pl) Linux Ubuntu Xenial Xerus (development branch)
Memory Usage: 382 MB / 869 MB (103 MB allocated, but free)
Java version: 1.7.0_91, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u91-2.6.3-1
VM arguments: [-Djosm.home=xxx]
Dataset consistency test: No problems found

Plugins:
- Mapillary (31772)
- OpeningHoursEditor (31772)
- PicLayer (31772)
- apache-commons (31772)
- apache-http (31772)
- measurement (31772)
- reverter (31772)
- tageditor (31772)
- utilsplugin2 (31772)

Attachments (3)

Zrzut ekranu z 2015-11-20 23-43-28.png (62.3 KB) - added by anonymous 5 years ago.
Screenshot no.1
Zrzut ekranu z 2015-11-20 23-47-21.png (19.4 KB) - added by anonymous 5 years ago.
Screenshot no.2
Zrzut ekranu z 2015-11-21 00-00-28.png (18.7 KB) - added by anonymous 5 years ago.
Screenshot no.2 original tags

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by anonymous

Screenshot no.1

Changed 5 years ago by anonymous

Screenshot no.2

Changed 5 years ago by anonymous

Screenshot no.2 original tags

comment:1 Changed 5 years ago by Don-vip

Description: modified (diff)
Keywords: linux debian ubuntu added

comment:2 Changed 5 years ago by mdk

looks like a duplicate of #12022

comment:3 Changed 5 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #12022.

comment:4 Changed 5 years ago by anonymous

Some time after mapping I found this in terminal (few times):

java.lang.IndexOutOfBoundsException: Invalid index
	at javax.swing.DefaultRowSorter.convertRowIndexToModel(DefaultRowSorter.java:514)
	at javax.swing.JTable.convertRowIndexToModel(JTable.java:2642)
	at javax.swing.JTable.getValueAt(JTable.java:2717)
	at javax.swing.JTable$AccessibleJTable$AccessibleJTableCell.getCurrentAccessibleContext(JTable.java:7962)
	at javax.swing.JTable$AccessibleJTable$AccessibleJTableCell.addPropertyChangeListener(JTable.java:8202)
	at org.GNOME.Accessibility.AtkWrapper.registerPropertyChangeListener(AtkWrapper.java:625)

comment:5 in reply to:  4 Changed 5 years ago by Don-vip

Replying to anonymous:

Some time after mapping I found this in terminal (few times):

already reported in #12062 but I don't know where does this problem come from.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.