Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12110 closed defect (fixed)

wrong translation of relation "description" in Selection and Relation toggle dialog

Reported by: naoliv Owned by: team
Priority: normal Milestone: 15.11
Component: Core Version:
Keywords: i18n Cc:

Description (last modified by stoecker)

I was seeing that natural=wood multipolygons are translated as madeira in Portuguese (which is wrong for this case; it has a different meaning).

Looking at Launchpad I saw only one place where we can translate wood:

https://i.imgur.com/DjwHyH6.png

Since there isn't any other string translated as madeira, I guess that JOSM is also taking natural=wood from this same translation.

Another translation for wood (when used as natural=wood) is needed.


Attachments (2)

floresta.png (8.8 KB) - added by Klumbumbus 4 years ago.
relation.png (23.8 KB) - added by Klumbumbus 4 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 4 years ago by Klumbumbus

The string for the preset item "natural=wood" is "Wood" (with capital letter).
The string is https://translations.launchpad.net/josm/trunk/+pots/josm/pt_BR/6545/+translate , which is translated with "Floresta" and this is also what JOSM displays.

Changed 4 years ago by Klumbumbus

Attachment: floresta.png added

comment:2 Changed 4 years ago by Klumbumbus

Resolution: invalid
Status: newclosed

comment:3 Changed 4 years ago by Klumbumbus

Resolution: invalid
Status: closedreopened

Ah, now I see that it is different for multipolygons.

comment:4 Changed 4 years ago by naoliv

The problem is with relations.
I don't know if you can export LC_ALL=pt_BR and run JOSM, but I see this:

https://i.imgur.com/h16kQzE.png

This "madeira" is coming from nowhere or from the translation that I sent on the first message :-)

Last edited 4 years ago by stoecker (previous) (diff)

comment:5 Changed 4 years ago by Klumbumbus

Description: modified (diff)
Summary: Missing translation for "natural=wood" in pt_BRwrong translation of relation "description" in Selection and Relation toggle dialog

The problem is that JOSM displays there the value of one tag (I don't know the rules, which tag to choose), in this case the value of the key "natural" and translates it if a translation is availble. Since the wood in natural=wood is written with lower case letter, the wrong translation is used.

Changed 4 years ago by Klumbumbus

Attachment: relation.png added

comment:6 Changed 4 years ago by Don-vip

Keywords: i18n added
Milestone: 15.11

comment:7 Changed 4 years ago by stoecker

Description: modified (diff)

comment:8 Changed 4 years ago by stoecker

Resolution: fixed
Status: reopenedclosed

The code for this is in DefaultNameFormatter.java. We are using a lazy translation here. That means a context is used when existing, otherwise a text without context is used.

We have a list of exceptions like these relation names in specialmessages.java in main SVN i18n directory.

I added natural=wood in [o31771]. Feel free to add some other common types where necessary. Relations are used much more than at the time of implementing this.

comment:9 Changed 4 years ago by Klumbumbus

So, now after [o31771] there is one more string to translate in Launchpad, which is used for the relation?

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.