Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12073 closed defect (fixed)

"sort values" results in exception

Reported by: malenki Owned by: team
Priority: critical Milestone: 15.11
Component: Core Version: latest
Keywords: template_report regression Cc: simon04

Description

What steps will reproduce the problem?

  1. Have a data layer in JOSM with at least one object with two tags
  2. select it
  3. Click on "Value" in the properties window.

What is the expected result?

Sort values

What happens instead?

Exception

Please provide any additional information below. Attach a screenshot if possible.

The possibility to sort keys and values and seemingly also the issue was introduced between r8973 and r8985, sorting keys works fine.
I set the priority to "critical" since it is nearly impossible to continue mapping after having triggered this exception because every selection and de-selection of tagged objects will throw another exception.
Tested with blank ~/.josm
Exists also in r8993

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-11-03 02:34:09
Last Changed Author: Don-vip
Revision: 8985
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-11-03 01:12:42 +0100 (Tue, 03 Nov 2015)
Last Changed Rev: 8985

Identification: JOSM/1.5 (8985 de) Linux LMDE 2 Betsy
Memory Usage: 303 MB / 2222 MB (144 MB allocated, but free)
Java version: 1.7.0_85, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u85-2.6.1-6+deb8u1
VM arguments: [-Dsun.java2d.opengl=false]
Dataset consistency test: No problems found


Last errors/warnings:
- E: java.lang.ClassCastException: java.util.TreeMap cannot be cast to java.lang.String

java.lang.ClassCastException: java.util.TreeMap cannot be cast to java.lang.String
	at java.text.Collator.compare(Collator.java:327)
	at javax.swing.DefaultRowSorter.compare(DefaultRowSorter.java:968)
	at javax.swing.DefaultRowSorter.access$100(DefaultRowSorter.java:112)
	at javax.swing.DefaultRowSorter$Row.compareTo(DefaultRowSorter.java:1376)
	at javax.swing.DefaultRowSorter$Row.compareTo(DefaultRowSorter.java:1366)
	at java.util.Arrays.mergeSort(Arrays.java:573)
	at java.util.Arrays.legacyMergeSort(Arrays.java:478)
	at java.util.Arrays.sort(Arrays.java:470)
	at javax.swing.DefaultRowSorter.sort(DefaultRowSorter.java:607)
	at javax.swing.DefaultRowSorter.setSortKeys(DefaultRowSorter.java:319)
	at javax.swing.DefaultRowSorter.toggleSortOrder(DefaultRowSorter.java:480)
	at javax.swing.plaf.basic.BasicTableHeaderUI$MouseInputHandler.mouseClicked(BasicTableHeaderUI.java:112)
	at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:270)
	at java.awt.Component.processMouseEvent(Component.java:6519)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3312)
	at java.awt.Component.processEvent(Component.java:6281)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4872)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4501)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:747)
	at java.awt.EventQueue.access$300(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:706)
	at java.awt.EventQueue$3.run(EventQueue.java:704)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:720)
	at java.awt.EventQueue$4.run(EventQueue.java:718)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:717)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (0)

Change History (4)

comment:1 Changed 4 years ago by Don-vip

Milestone: 15.11

comment:2 Changed 4 years ago by Don-vip

Cc: simon04 added
Keywords: regression added

introduced in r8980?

comment:3 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

In 8996/josm:

fix #12073 - Properties dialog: make sorting by values work w/o CCE

comment:4 Changed 4 years ago by Don-vip

Ticket #12079 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.