Modify

Opened 4 years ago

Closed 4 years ago

#12016 closed defect (fixed)

History dialog in rare cases shows a way was reversed when it wasn't.

Reported by: rickmastfan67 Owned by: team
Priority: major Milestone: 15.11
Component: Core Version: latest
Keywords: history regression Cc: simon04

Description (last modified by rickmastfan67)

I just happened to run across this when repairing a highway interchange since it had been completely realigned and needed to be fixed in the OSM data. I don't think this is caused by the 'utilsplugin2' plugin's "Replace Geometry", but something that has gone wrong inside of the history display.

Steps to reproduce:

  1. Download one of the following ways into JOSM: https://www.openstreetmap.org/way/205003377 https://www.openstreetmap.org/way/205003306 https://www.openstreetmap.org/way/31705157 (all 3 exhibit this bug)
  2. Select the way you downloaded (let's use Way 205003377 as the example here), and then hit 'Ctrl+H' to bring up the history for the way.
  3. Once the history window is open, go to the 'Nodes' view.
  4. Start off by comparing V1 w/ V1, and notice that Node 2149795917 is the first node, and 2149795972 is the last node.
  5. Now, compare V1 w/ V2.

What happens:
Way 205003377 is displayed as being reversed between versions 1 & 2 with Node 2149795917 still being the first node, and 2149795972 the last node of the way.

What should happen:
Way 205003377 shouldn't be displayed as being reversed between versions 1 & 2 since the start/end nodes are still exactly the same for the way, and so is the direction.

If you view the history for any of the ways listed above and look at the version right before my edits, you can see that the same nodes are the starting/ending nodes in each version. No idea why JOSM is doing this. Will attempt to find a possible regression window if there is one.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-10-28 02:32:10
Last Changed Author: simon04
Revision: 8964
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-10-27 23:40:20 +0100 (Tue, 27 Oct 2015)
Last Changed Rev: 8964

Identification: JOSM/1.5 (8964 en) Windows 7 64-Bit
Memory Usage: 371 MB / 1820 MB (60 MB allocated, but free)
Java version: 1.7.0_79, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- OpeningHoursEditor (31603)
- buildings_tools (31640)
- measurement (31648)
- osmarender (31603)
- reverter (31625)
- turnrestrictions (31638)
- undelete (31603)
- utilsplugin2 (31655)

Attachments (1)

ticket12016.osm (4.0 KB) - added by rickmastfan67 4 years ago.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by rickmastfan67

Attachment: ticket12016.osm added

comment:1 Changed 4 years ago by rickmastfan67

Description: modified (diff)
Priority: normalmajor
Summary: History dialog in rare cases shows a way was reversed when it wasn't after replacing the geometry of it.History dialog in rare cases shows a way was reversed when it wasn't.

Simplified the steps to reproduce this above, as it still happens after the updated way was uploaded to the OSM database.

comment:2 Changed 4 years ago by rickmastfan67

Keywords: regression added

Ok, after some testing, I've narrowed down to when this problem was introduced.

r8212 correctly shows that the way wasn't reversed.
r8229+ shows that the way was reversed, when it really wasn't.

It seems this was introduced by the changes in [8219] (#6994) to introduce the arrows in the history when a way is reversed.

Last edited 4 years ago by rickmastfan67 (previous) (diff)

comment:3 Changed 4 years ago by simon04

Milestone: 15.11

comment:4 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

In 8976/josm:

fix #12016 - History dialog sometimes incorrectly shows a way as reversed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.