Modify

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#11942 closed defect (fixed)

Crash when trying to display custom tms layer

Reported by: EdLoach Owned by: simon04
Priority: normal Milestone: 15.10
Component: Core imagery Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Download a small area of Clacton, Essex, UK
  2. Define a custom imagery layer tms:http://www.loach.me.uk/Lidar/2m/{zoom}/{x}/{-y}.png
  3. Add that imagery layer

What is the expected result?

See the imagery layer

What happens instead?

Error messages, followed by lack of responsiveness if messages dismissed. Console shows this where errors begin (based on downloading St John's Church, Great Clacton):
INFO: GET http://www.loach.me.uk/Lidar/2m/17/65957/87661.png -> 200
INFO: GET http://www.loach.me.uk/Lidar/2m/17/65957/87662.png -> 200
INFO: GET http://www.loach.me.uk/Lidar/2m/17/65956/87661.png -> 200
INFO: GET http://www.loach.me.uk/Lidar/2m/17/65956/87662.png -> 200
ERROR: java.lang.IllegalArgumentException: Unknown image type 0

Please provide any additional information below. Attach a screenshot if possible.

Revision: 8800
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: simon04
Last Changed Date: 2015-09-27 22:11:06 +0200 (Sun, 27 Sep 2015)
Build-Date: 2015-09-28 01:32:03
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8800

Identification: JOSM/1.5 (8800 en_GB) Windows 10 64-Bit
Memory Usage: 128 MB / 989 MB (31 MB allocated, but free)
Java version: 1.8.0_60, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugins:
- Mapillary (31550)
- OpeningHoursEditor (31241)
- commons-imaging (31241)
- geochat (31241)
- geotools (31126)
- gpxfilter (31241)
- jts (31126)
- measurement (31289)
- missingRoads (31)
- opendata (31241)
- photo_geotagging (31241)
- reverter (31241)
- terracer (31241)
- utilsplugin2 (31463)

Last errors/warnings:
- E: java.lang.IllegalArgumentException: Unknown image type 0
- E: java.lang.IllegalArgumentException: Unknown image type 0
- E: java.lang.IllegalArgumentException: Unknown image type 0

java.lang.IllegalArgumentException: Unknown image type 0
	at java.awt.image.BufferedImage.<init>(Unknown Source)
	at org.openstreetmap.josm.gui.layer.ImageryLayer$GammaImageProcessor.process(ImageryLayer.java:297)
	at org.openstreetmap.josm.gui.layer.ImageryLayer.applyImageProcessors(ImageryLayer.java:372)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.paintTileImages(AbstractTileSourceLayer.java:1036)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.paint(AbstractTileSourceLayer.java:1443)
	at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:645)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:729)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JSplitPane.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintToOffscreen(Unknown Source)
	at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(Unknown Source)
	at javax.swing.RepaintManager$PaintManager.paint(Unknown Source)
	at javax.swing.RepaintManager.paint(Unknown Source)
	at javax.swing.JComponent._paintImmediately(Unknown Source)
	at javax.swing.JComponent.paintImmediately(Unknown Source)
	at javax.swing.RepaintManager$4.run(Unknown Source)
	at javax.swing.RepaintManager$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.prePaintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.access$1200(Unknown Source)
	at javax.swing.RepaintManager$ProcessingRunnable.run(Unknown Source)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.WaitDispatchSupport$2.run(Unknown Source)
	at java.awt.WaitDispatchSupport$4.run(Unknown Source)
	at java.awt.WaitDispatchSupport$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(Unknown Source)
	at java.awt.Dialog.show(Unknown Source)
	at java.awt.Component.show(Unknown Source)
	at java.awt.Component.setVisible(Unknown Source)
	at java.awt.Window.setVisible(Unknown Source)
	at java.awt.Dialog.setVisible(Unknown Source)
	at org.openstreetmap.josm.gui.ExtendedDialog.setVisible(ExtendedDialog.java:502)
	at org.openstreetmap.josm.gui.ExtendedDialog.showDialog(ExtendedDialog.java:290)
	at org.openstreetmap.josm.tools.BugReportExceptionHandler$BugReporterThread$BugReporterWorker.run(BugReportExceptionHandler.java:103)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (5)

comment:1 by EdLoach, 9 years ago

I forgot to mention that the layer seems fine in Potlatch2 when I tested it there.

comment:2 by simon04, 9 years ago

Milestone: 15.10
Owner: changed from team to simon04
Status: newassigned

comment:3 by simon04, 9 years ago

Resolution: fixed
Status: assignedclosed

In 8832/josm:

fix #11942 - Make gamma correction more robust to mysterious image types

comment:4 by Don-vip, 9 years ago

Ticket #11964 has been marked as a duplicate of this ticket.

comment:5 by simon04, 8 years ago

Ticket #12021 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.