Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11884 closed defect (fixed)

Turnrestrictions plugin will not open editor, throws NoSuchMethodError

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Plugin turnrestrictions Version: tested
Keywords: template_report NoSuchMethodError Cc:

Description

What steps will reproduce the problem?

  1. Open JOSM
  2. Display the turn restriction panel
  3. (If there are TR in the currently loaded data they are displayed in the panel)
  4. Select "Create new turn restriction" from the turnrestriction panel

What is the expected result?

The advanced editor window for turnrestrictions opens.

What happens instead?

The advanced editor does not open, the NoSuchMethodError is thrown to the console window (see stack trace below).

Please provide any additional information below. Attach a screenshot if possible.

java.lang.NoSuchMethodError: org.openstreetmap.josm.gui.tagging.TagEditorPanel.<
init>(Lorg/openstreetmap/josm/gui/tagging/TagEditorModel;Lorg/openstreetmap/josm
/gui/tagging/PresetHandler;I)V
        at org.openstreetmap.josm.plugins.turnrestrictions.editor.AdvancedEditor
Panel.buildTagEditorPanel(AdvancedEditorPanel.java:45)
        at org.openstreetmap.josm.plugins.turnrestrictions.editor.AdvancedEditor
Panel.buildSplitPane(AdvancedEditorPanel.java:79)
        at org.openstreetmap.josm.plugins.turnrestrictions.editor.AdvancedEditor
Panel.build(AdvancedEditorPanel.java:92)
        at org.openstreetmap.josm.plugins.turnrestrictions.editor.AdvancedEditor
Panel.<init>(AdvancedEditorPanel.java:104)
        at org.openstreetmap.josm.plugins.turnrestrictions.editor.TurnRestrictio
nEditor.buildEditorPanel(TurnRestrictionEditor.java:136)
        at org.openstreetmap.josm.plugins.turnrestrictions.editor.TurnRestrictio
nEditor.buildContentPanel(TurnRestrictionEditor.java:158)
        at org.openstreetmap.josm.plugins.turnrestrictions.editor.TurnRestrictio
nEditor.build(TurnRestrictionEditor.java:204)
        at org.openstreetmap.josm.plugins.turnrestrictions.editor.TurnRestrictio
nEditor.<init>(TurnRestrictionEditor.java:234)
        at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictions
ListDialog$NewAction.run(TurnRestrictionsListDialog.java:307)
        at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictions
ListDialog$NewAction.actionPerformed(TurnRestrictionsListDialog.java:314)
        ... swing ...
Revision: 8677
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2015-08-21 22:18:03 +0200 (Fri, 21 Aug 2015)
Build-Date: 2015-08-21 23:32:08
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8677

Identification: JOSM/1.5 (8677 de) Windows 7 64-Bit
Memory Usage: 580 MB / 3632 MB (306 MB allocated, but free)
Java version: 1.8.0_60, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Djava.net.useSystemProxies=true]

Plugins:
- buildings_tools (31361)
- jts (31126)
- kendzi3d (1.0.186)
- kendzi3d-jogl (41)
- log4j (31231)
- mirrored_download (31294)
- poly (31241)
- reverter (31241)
- scripting (30710)
- terracer (31241)
- turnrestrictions (31562)
- utilsplugin2 (31463)

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o31578:31579]. Unfortunately to have the good plugin you have to either:

comment:2 Changed 4 years ago by simon04

Ticket #11972 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.