Modify

Opened 6 years ago

Closed 17 months ago

#11806 closed defect (fixed)

JOSM unusable on Linux with HIDPI/Retina displays

Reported by: mjog Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Linux javabug hidpi retina Cc: Klumbumbus

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Install JOSM on Linux machine with HIDPI display
  2. Launch JOSM

What is the expected result?

UI is scaled to an appropriate resolution.

What happens instead?

With the exception of the font (which is picked up from my desktop settings), the UI is not scaled, making it impossible to use.

In particular: Icons are too small to see and click, space between UI elements is non-existent, map elements (way lines, nodes, labels, etc) are too small to see and click. Custom cursors are not scaled.

Screenshot of JOSM on Ubuntu GNOME 15.04 on a 13" Retina MBP

Please provide any additional information below. Attach a screenshot if possible.

Revision: 8677
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2015-08-21 22:18:03 +0200 (Fri, 21 Aug 2015)
Build-Date: 2015-08-21 23:32:08
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8677

Identification: JOSM/1.5 (8677 en_AU) Linux Ubuntu 15.04
Memory Usage: 874 MB / 3545 MB (313 MB allocated, but free)
Java version: 1.8.0_45-internal, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]

Plugins:
- PicLayer (31241)
- buildings_tools (31361)
- reverter (31241)

Attachments (3)

Screenshot from 2015-08-25 12-23-41.png (554.8 KB) - added by mjog 6 years ago.
Screenshot of JOSM on Ubuntu GNOME 15.04 on a 13" Retina MBP
2018-04-08-183257_2560x1440_scrot.png (374.1 KB) - added by nermolov1@… 4 years ago.
2560x1440 on 13in display with GDK_SCALE=2
Screenshot from 2020-06-03 22-20-23.png (507.1 KB) - added by anonymous 18 months ago.
Debian 10 GNOME HP Elite x2 1012 G2

Download all attachments as: .zip

Change History (21)

Changed 6 years ago by mjog

Screenshot of JOSM on Ubuntu GNOME 15.04 on a 13" Retina MBP

comment:1 Changed 6 years ago by mjog

Related to #8764, but that is for MacOSX-specific issues.

comment:2 Changed 6 years ago by Don-vip

Keywords: Linux javabug hidpi added

Can you please try with Java 8u60?

comment:3 Changed 6 years ago by Klumbumbus

Cc: Klumbumbus added

comment:4 in reply to:  2 Changed 6 years ago by mjog

Replying to Don-vip:

Can you please try with Java 8u60?

The problem exists with both Oracle 1.8.0_60-b27 and OpenJDK 1.8.0_45-internal-b14.

comment:5 Changed 6 years ago by Don-vip

Description: modified (diff)

comment:6 Changed 6 years ago by Don-vip

Description: modified (diff)

comment:7 Changed 6 years ago by Don-vip

Keywords: high dpi retina added; hidpi removed

Same kind of problem than #9995. Oracle needs to make Java high dpi compliant on all platforms, not only OSX. See javabug:8058742 for a Linux example.

comment:8 Changed 6 years ago by mdk

Also related to #11719 (?)

comment:9 Changed 6 years ago by Don-vip

HiDPI Graphics on Windows and Linux is covered by JEP 263 and may be available in Java 9.

comment:10 Changed 6 years ago by Don-vip

Latest snapshots of Java 9 contain hidpi support for Linux and Windows, you could give it a try: https://jdk9.java.net/download/

comment:11 Changed 6 years ago by mjog

Trying it out under JDK 9 Build 99, and under GNOME 3 with scaling-factor set to 2 (i.e. set up correctly for a hi-dpi display) I find no change compared JDK8 by default.

To get the UI to scale, I need to run JOSM with the environment var GDK_SCALE=2:

GDK_SCALE=2 ~/local/jdk-9/bin/java -jar /usr/share/josm/josm.jar

When doing so, the UI is scaled by 2, but are still some issues:

  1. App icons are pixelated
  2. Dialogs windows are all about half the hight they need to be, so contents are obscured. Maybe a layout issue?
  3. The map needs to be made HIDPI aware - lines and text size (e.g. way names) are drawn badly pixelated
  4. Map custom cursors are not scaled and hence are tiny
  5. Under the GTK L&F, UI text labels are scaled twice (this and requiring the GDK_SCALE env var seem likely to be JDK bugs however)

So, good progress, but probably needs some app support to be brought back up to scratch.

comment:12 Changed 4 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #9995.
Java 9 has been released so please update to this version. If any problem, please report them in #9995

Changed 4 years ago by nermolov1@…

2560x1440 on 13in display with GDK_SCALE=2

comment:13 Changed 4 years ago by nermolov1@…

Resolution: duplicate
Status: closedreopened

On my 2560x1440 @ 13in display JOSM is still unusable. No HiDPI scaling creates a microscopic gui and GDK_SCALE=2 renders everything too large in order to be usable. GDK_SCALE=1.5 does nothing.

Perhaps the Arduino IDE's HiDPI implementation could be investigated? It allows setting a "150%" scaling factor which renders a well scaled UI.

2560x1440 on 13in display with GDK_SCALE=2

comment:14 Changed 2 years ago by Don-vip

Ticket #18496 has been marked as a duplicate of this ticket.

comment:15 Changed 2 years ago by Don-vip

Keywords: hidpi added; high dpi removed

comment:16 in reply to:  13 Changed 2 years ago by skyper

Replying to nermolov1@…:

On my 2560x1440 @ 13in display JOSM is still unusable. No HiDPI scaling creates a microscopic gui and GDK_SCALE=2 renders everything too large in order to be usable. GDK_SCALE=1.5 does nothing.

Have a look at arch linux wiki page HiDPI how to work around your problem.

Changed 18 months ago by anonymous

Debian 10 GNOME HP Elite x2 1012 G2

comment:17 Changed 17 months ago by johsin18

IMHO we should close this bug unless it's confirmed that it can be reproduced with Java>=9.

comment:18 Changed 17 months ago by stoecker

Resolution: fixed
Status: reopenedclosed

There were many HIDPI changes over the time. Open new report in case of remaining issues with recent Java version.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.