Modify

Opened 4 years ago

Closed 4 years ago

#11795 closed enhancement (fixed)

taginfo-extract also external presets

Reported by: simon04 Owned by: team
Priority: normal Milestone: 15.09
Component: Core Version:
Keywords: Cc:

Description

Follow-up of #10512.

Attachments (2)

11795.patch (6.4 KB) - added by simon04 4 years ago.
Presets_Nepal-preset.xml (10.4 KB) - added by simon04 4 years ago.

Download all attachments as: .zip

Change History (22)

Changed 4 years ago by simon04

Attachment: 11795.patch added

comment:1 Changed 4 years ago by Don-vip

I'm going to launch a new build, you can commit this change in the current milestone if you want, as it does not have any impact on the software :)

comment:2 Changed 4 years ago by simon04

In 8681/josm:

see #11795 - taginfo-extract also external presets

comment:3 Changed 4 years ago by simon04

Summary: [Patch] taginfo-extract also external presetstaginfo-extract also external presets

Would someone please set up a cron job on the server? Afterwards we can file a pull-request for the inclusion: https://github.com/joto/taginfo-projects

Unfortunately, the script outputs a lot of icon loading warnings/errors. Without changing a lot of code, I wasn't able to get rid of them …

comment:4 Changed 4 years ago by Don-vip

I tried to add the cron job but it fails:

Caught: groovy.lang.MissingPropertyException: Exception evaluating property '' for org.openstreetmap.josm.gui.tagging.TaggingPresetReader$HashSetWithLast, Reason: groovy.lang.MissingPropertyException: No such property:  for class: org.openstreetmap.josm.gui.tagging.TaggingPresetMenu
Possible solutions: keys, icon, name, type, class, rawName
groovy.lang.MissingPropertyException: Exception evaluating property '' for org.openstreetmap.josm.gui.tagging.TaggingPresetReader$HashSetWithLast, Reason: groovy.lang.MissingPropertyException: No such property:  for class: org.openstreetmap.josm.gui.tagging.TaggingPresetMenu
Possible solutions: keys, icon, name, type, class, rawName
        at taginfoextract.run_presets(taginfoextract.groovy:240)
        at taginfoextract$run_presets.call(Unknown Source)
        at taginfoextract.main(taginfoextract.groovy:188)
make: *** [taginfo_nodep] Error 1

comment:5 Changed 4 years ago by Don-vip

In 8687/josm:

see #11795 - add taginfo target to Ant build

comment:6 Changed 4 years ago by Don-vip

In 8690/josm:

see #11795 - fix error

comment:7 Changed 4 years ago by Don-vip

In 8692/josm:

see #11795 - fix HeadlessException with Jenkins

comment:9 Changed 4 years ago by simon04

Thanks for the fixes, esp. the typo fixed in r8690, Don-vip!

comment:10 Changed 4 years ago by Don-vip

you're welcome :) now we could investigate all these warnings/errors and see if we can fix some of them...

comment:11 Changed 4 years ago by simon04

In 8710/josm:

see #11795 - taginfoextract: avoid "Could not get presets icon" by not loading icons

comment:12 Changed 4 years ago by simon04

Now, the only preset with errors is Presets/Nepal? since it specifies empty types (type="").

comment:13 in reply to:  12 Changed 4 years ago by Klumbumbus

Replying to simon04:

Now, the only preset with errors is Presets/Nepal? since it specifies empty types (type="").

I think we should simply remove them from this preset. This preset is basically unmodified since its creation 2 years ago. It is not expacted that someone adds the types in the (near) future.

comment:14 Changed 4 years ago by simon04

In 8717/josm:

see #11795 - taginfoextract: clean pref* directories after processing

comment:15 Changed 4 years ago by simon04

Are there any usage statistics on Presets/Nepal? I wouldn't object removing this preset. Any thoughts?

Changed 4 years ago by simon04

Attachment: Presets_Nepal-preset.xml added

comment:16 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

Presets/Nepal? deleted. Here's the archive, attachment:Presets_Nepal-preset.xml

comment:18 Changed 4 years ago by simon04

"As designed" ;-). Icons were never expected to work. While processing, they should just not trigger warnings on the commandline. One could investigate the effort to include them (as data URLs), though …

comment:19 Changed 4 years ago by Klumbumbus

OK, I thought it is a bug, because icons of the internal preset are included. We can close this ticket again, except someone is willing to add this functionality.

comment:20 Changed 4 years ago by simon04

Resolution: fixed
Status: reopenedclosed

I don't ;-) – at least not now and unless there is a certain demand for this feature

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.