Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11785 closed defect (fixed)

Bing imagey "close to ground" zoom functions not really working anymore after recent change

Reported by: rickmastfan67 Owned by: team
Priority: major Milestone: 15.08
Component: Core imagery Version: latest
Keywords: Bing regression Cc: wiktorn

Description

In the past, when you hit the max zoom level of zoom in Bing imagery, JOSM would zoom in on the last level of imagery available. However, now when you're panning around @ say, 24ft, if you hadn't previously loaded the imagery from Bing level 19, you are greeted with no imagery. Now, this still works partially if you had already previously loaded the imagery on said last zoom level. I compared the current latest (r8660) with the current tested (r8491). The tested version works correctly and loads the level 19 imagery, even at 24ft.

I think this is something that needs to be fixed before the next 'tested' comes out. I did some testing of the 'latest' files to see where exactly this functionally got broken. Works correctly in r8646, and is broken in r8651. So, as far as I can tell, if I had to make a guess, it was [8647] that broke it.

Steps to reproduce:

  1. Load the attached OSM file (this allows you to get the exact area I noticed this in which has a max imagery level of 19 in Bing).
  2. Zoom in to 27.3 ft.
  3. Open Bing imagery.
  4. Notice there are tons of 'Error: No tile at this zoom level' because JOSM is trying to load level 20 imagery instead of showing a zoomed in copy of level 19.
  5. Now, zoom out and then back in to 27.3 ft. This should get JOSM to load Bing 19 at 27.3 ft.
  6. Now, pan in any direction for awhile.

What happens:
After a while, you'll encounter a cut off of the imagery. This is the distance of where the imagery that got loaded in Step 5.

What should happen:
JOSM should automatically download and show Bing level 19 imagery (which is what it does in the last 'tested'). MapBox imagery doesn't suffer from this problem in this area, as it correctly dispalys it's max zoom level of 19 in this area.

This happens always when you try to zoom in one level farther than Bing supports in that area. And since the 'Bing' imagery entry in JOSM has a built in max level of 22, this problem can happen almost anywhere.

JOSM used to show that 'Error: No tile at this zoom level' message and then automatically download and display a 'zoomed in' version of the lowest imagery level available in that area.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-08-13 01:32:08
Last Changed Author: Don-vip
Revision: 8660
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-08-12 23:30:18 +0200 (Wed, 12 Aug 2015)
Last Changed Rev: 8660

Identification: JOSM/1.5 (8660 en) Windows 7 64-Bit
Memory Usage: 630 MB / 1820 MB (452 MB allocated, but free)
Java version: 1.7.0_79, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- OpeningHoursEditor (31241)
- buildings_tools (31361)
- measurement (31289)
- mirrored_download (31294)
- osmarender (31241)
- reverter (31241)
- turnrestrictions (31241)
- undelete (31241)
- utilsplugin2 (31463)

Attachments (1)

ticket11785.osm (44.3 KB) - added by rickmastfan67 6 years ago.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by rickmastfan67

Attachment: ticket11785.osm added

comment:1 Changed 6 years ago by Don-vip

Keywords: regression added
Milestone: 15.08

comment:2 Changed 6 years ago by Don-vip

Wiktor, can you please have a look at it? If possible, I'd like to include the fix in the new release.

comment:3 Changed 6 years ago by wiktorn

Resolution: fixed
Status: newclosed

In 8673/josm:

Bing fixes.

  • Pass and handle error on url creation (attribution not loaded yet). Closes: #11776
  • Properly identify "no tiles at this zoom level" situation in tile sets. This tiles are never marked as loaded. Closes: #11785

comment:4 Changed 6 years ago by Don-vip

Thanks! :)

comment:5 Changed 6 years ago by rickmastfan67

Just was able to test this and the fix works. :)

Thank again wiktorn!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.