Modify

Opened 4 years ago

Closed 4 years ago

#11770 closed defect (fixed)

WMS Service errors because of HTTP/302 redirects

Reported by: tyr_asd Owned by: wiktorn
Priority: normal Milestone: 15.08
Component: Core imagery Version: tested
Keywords: WMS HTTP redirect 302 Cc:

Description

Here is a WMS Service which does HTTP/302 redirects to change the protocol from http to https. This seems to confuse JOSM:

Image couldn't be fetched: http://gis-eppan.gvcc.net/WMS/Eppan?FORMAT=image/jpeg&VERSION=1.1.1&SERVICE=WMS&REQUEST=GetMap&LAYERS=apotheke_symbol,arzt_symbol,weisses_kreuz_symbol,gesundheitsspren_sym&STYLES=&SRS=EPSG:4326&WIDTH=500&HEIGHT=500&BBOX=11.2567447,46.4479331,11.2579605,46.4487708
	at org.openstreetmap.josm.io.imagery.WMSGrabber.fetch(WMSGrabber.java:173)
	at org.openstreetmap.josm.io.imagery.WMSGrabber.attempt(WMSGrabber.java:132)
	at org.openstreetmap.josm.io.imagery.WMSGrabber.run(WMSGrabber.java:116)
	at java.lang.Thread.run(Thread.java:745)
Caused by: java.io.IOException: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>302 Found</title>
// -- snip --

Here are the corresponding HTTP headers:

$ curl -i "http://gis-eppan.gvcc.net/WMS/Eppan?version=1.3.0&service=WMS&request=GetLegendGraphic&sld_version=1.1.0&layer=tankstelle_gebaeude&format=image/png&STYLE=default"   
HTTP/1.1 302 Found
Date: Sat, 08 Aug 2015 13:35:50 GMT
Server: Apache/2.2.8 (Ubuntu) proxy_html/3.0.0 mod_ssl/2.2.8 OpenSSL/0.9.8g
Location: https://gis-eppan.gvcc.net/WMS/Eppan?version=1.3.0&service=WMS&request=GetLegendGraphic&sld_version=1.1.0&layer=tankstelle_gebaeude&format=image/png&STYLE=default
// -- snip --

Other software such as QGIS doesn't have problems consuming this WMS service.

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by wiktorn

Milestone: 15.08
Owner: changed from team to wiktorn
Status: newassigned

comment:2 Changed 4 years ago by wiktorn

In 8649/josm:

  • performance improvements - move all cache accesses to worker thread, as now, mostly we will have accesses to disks
  • follow HTTP 302 redirection when downloading tiles. Addresses: #11770

comment:3 Changed 4 years ago by wiktorn

Resolution: fixed
Status: assignedclosed

In 8650/josm:

Follow HTTP(S) redirects in Add WMS wizzard / GetLayers. Closes: #11770

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain wiktorn.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.