Modify

Opened 4 years ago

Last modified 4 years ago

#11675 reopened enhancement

UtilsPlugin2 Menus don't show up

Reported by: Stern77 Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Open JOSM
  2. Create new Layer or Open .osm File or Download map data from osm server
  3. Look at tool bar at the left side of the screen

What is the expected result?

UtilsPlugin2 Menu "More tools" and "Selection" shall be shown

What happens instead?

None of those menus are shown. Plugin can't be used at all, see:
https://josm.openstreetmap.de/wiki/Help/Plugin/UtilsPlugin2

Please provide any additional information below. Attach a screenshot if possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-06-16 21:45:58
Last Changed Author: Don-vip
Revision: 8491
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-06-16 23:27:08 +0200 (Tue, 16 Jun 2015)
Last Changed Rev: 8491

Identification: JOSM/1.5 (8491 de) Windows 7 64-Bit
Memory Usage: 93 MB / 247 MB (24 MB allocated, but free)
Java version: 1.7.0_71, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by rickmastfan67

It doesn't look like you have the plugin installed yet. That's why you can't access those features. Follow the steps below to fix this.

  1. F12 > Plugins (the icon that looks like a plug going into the wall)
  2. Then hit the 'Download List' button.
  3. Then scroll down to the bottom on the plugin list that loaded.
  4. Find the 'UtilsPlugin2' plugin on the list (7th from the bottom of the list), and click in the box beside it.
  5. Hit the 'Update Plugins' button on the bottom of the window.
  6. Follow the remaining prompts.

That's the only way to be able to access the addons that the 'UtilsPlugin2' plugin brings.

comment:2 Changed 4 years ago by Don-vip

Resolution: invalid
Status: newclosed

comment:3 Changed 4 years ago by anonymous

Resolution: invalid
Status: closedreopened
Type: defectenhancement

The plugin had been installed yet. I followed your steps anyway again but the described misbehaviour remained the same.

BUT I had a solution: The problem was, that the menu and toolboxes didn't show up because they were not actived. I had to make them show up by setting them visible in a preferences dialog: F12-->Elements on Toolbox (5th Icon from above). There you can add the necessary elements.

It would have been best that after installation those items would automatically set to visible.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The owner will remain team.
as The resolution will be set.
to The owner will be changed from team to the specified user.
The owner will change to Stern77
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.