Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11579 closed defect (fixed)

JOSM latest doesn't start. josm-latest of yesterday and josm-tested did work

Reported by: Polyglot Owned by: team
Priority: critical Milestone: 15.08
Component: Core Version:
Keywords: template_report regression Cc: simon04

Description

What steps will reproduce the problem?

  1. start JOSM

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-06-20 01:32:19
Last Changed Author: simon04
Revision: 8507
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-06-20 00:27:53 +0200 (Sat, 20 Jun 2015)
Last Changed Rev: 8507

Identification: JOSM/1.5 (8507 en) Windows 7 64-Bit
Memory Usage: 353 MB / 1111 MB (246 MB allocated, but free)
Java version: 1.7.0_40, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM

Plugins:
- AddrInterpolation
- ImportImagePlugin
- Mapillary
- OpeningHoursEditor
- PicLayer
- RoadSigns
- TombPlugin
- alignways
- buildings_tools
- commons-imaging
- contourmerge
- dataimport
- fieldpapers
- geochat
- geotools
- importvec
- jna
- jts
- livegps
- log4j (31231)
- mapdust
- measurement
- mirrored_download
- opendata
- pdfimport
- photo_geotagging
- photoadjust
- public_transport
- reverter
- scripting
- tag2link
- terracer
- todo
- turnrestrictions
- undelete
- utilsplugin2
- walkingpapers
- wikipedia

Last errors/warnings:
- E: Failed to locate image 'presets/crossing.png'
- W: Could not get presets icon presets/crossing.png
- E: Failed to locate image 'presets/crossing.png'
- W: Could not get presets icon presets/crossing.png
- E: java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: Invalid pseudo class specified: close. Cause: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: Invalid pseudo class specified: close. Cause: java.lang.IllegalArgumentException: Invalid pseudo class specified: close

java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: Invalid pseudo class specified: close
	at org.openstreetmap.josm.Main.<init>(Main.java:631)
	at org.openstreetmap.josm.gui.MainApplication.<init>(MainApplication.java:90)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:445)
Caused by: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: Invalid pseudo class specified: close
	at java.util.concurrent.FutureTask.report(Unknown Source)
	at java.util.concurrent.FutureTask.get(Unknown Source)
	at org.openstreetmap.josm.Main.<init>(Main.java:628)
	... 2 more
Caused by: java.lang.IllegalArgumentException: Invalid pseudo class specified: close
	at org.openstreetmap.josm.gui.mappaint.mapcss.Condition$PseudoClassCondition.createPseudoClassCondition(Condition.java:502)
	at org.openstreetmap.josm.gui.mappaint.mapcss.Condition.createPseudoClassCondition(Condition.java:74)
	at org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.class_or_pseudoclass(MapCSSParser.java:1452)
	at org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.selector(MapCSSParser.java:1060)
	at org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.child_selector(MapCSSParser.java:900)
	at org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.rule(MapCSSParser.java:870)
	at org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.sheet(MapCSSParser.java:854)
	at org.openstreetmap.josm.gui.mappaint.mapcss.MapCSSStyleSource.loadStyleSource(MapCSSStyleSource.java:393)
	at org.openstreetmap.josm.gui.mappaint.MapPaintStyles.loadStyleForFirstTime(MapPaintStyles.java:259)
	at org.openstreetmap.josm.gui.mappaint.MapPaintStyles.readFromPreferences(MapPaintStyles.java:252)
	at org.openstreetmap.josm.gui.preferences.map.MapPaintPreference.initialize(MapPaintPreference.java:181)
	at org.openstreetmap.josm.Main$6.initialize(Main.java:613)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:706)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:690)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (16)

comment:1 Changed 4 years ago by Klumbumbus

Cc: simon04 added
Milestone: 15.07

regression of r8494?

comment:2 Changed 4 years ago by Don-vip

Keywords: regression added

comment:3 Changed 4 years ago by simon04

MapCSS pseudo class close is unspecified (see Help/Styles/MapCSSImplementation#PseudoClasses). Before, unspecified classes have been ignored silently. Now, an exception is thrown.

comment:4 Changed 4 years ago by Polyglot

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-06-21 01:33:40
Last Changed Author: Don-vip
Revision: 8514
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-06-21 03:19:37 +0200 (Sun, 21 Jun 2015)
Last Changed Rev: 8514

Identification: JOSM/1.5 (8514 en) Windows 7 64-Bit
Memory Usage: 354 MB / 1111 MB (121 MB allocated, but free)
Java version: 1.7.0_40, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM

Plugins:
- AddrInterpolation
- ImportImagePlugin
- Mapillary
- OpeningHoursEditor
- PicLayer
- RoadSigns
- TombPlugin
- alignways
- buildings_tools
- commons-imaging
- contourmerge
- dataimport
- fieldpapers
- geochat
- geotools
- importvec
- jna
- jts
- livegps
- log4j (31231)
- mapdust
- measurement
- mirrored_download
- opendata
- pdfimport
- photo_geotagging
- photoadjust
- public_transport
- reverter
- scripting
- tag2link
- terracer
- todo
- turnrestrictions
- undelete
- utilsplugin2
- walkingpapers
- wikipedia

Last errors/warnings:
- E: Failed to locate image 'presets/crossing.png'
- W: Could not get presets icon presets/crossing.png
- E: Failed to locate image 'presets/crossing.png'
- W: Could not get presets icon presets/crossing.png
- E: java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: Invalid pseudo class specified: close. Cause: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: Invalid pseudo class specified: close. Cause: java.lang.IllegalArgumentException: Invalid pseudo class specified: close

java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: Invalid pseudo class specified: close
	at org.openstreetmap.josm.Main.<init>(Main.java:632)
	at org.openstreetmap.josm.gui.MainApplication.<init>(MainApplication.java:90)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:445)
Caused by: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: Invalid pseudo class specified: close
	at java.util.concurrent.FutureTask.report(Unknown Source)
	at java.util.concurrent.FutureTask.get(Unknown Source)
	at org.openstreetmap.josm.Main.<init>(Main.java:629)
	... 2 more
Caused by: java.lang.IllegalArgumentException: Invalid pseudo class specified: close
	at org.openstreetmap.josm.gui.mappaint.mapcss.Condition$PseudoClassCondition.createPseudoClassCondition(Condition.java:502)
	at org.openstreetmap.josm.gui.mappaint.mapcss.Condition.createPseudoClassCondition(Condition.java:74)
	at org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.class_or_pseudoclass(MapCSSParser.java:1452)
	at org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.selector(MapCSSParser.java:1060)
	at org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.child_selector(MapCSSParser.java:900)
	at org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.rule(MapCSSParser.java:870)
	at org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.sheet(MapCSSParser.java:854)
	at org.openstreetmap.josm.gui.mappaint.mapcss.MapCSSStyleSource.loadStyleSource(MapCSSStyleSource.java:394)
	at org.openstreetmap.josm.gui.mappaint.MapPaintStyles.loadStyleForFirstTime(MapPaintStyles.java:260)
	at org.openstreetmap.josm.gui.mappaint.MapPaintStyles.readFromPreferences(MapPaintStyles.java:253)
	at org.openstreetmap.josm.gui.preferences.map.MapPaintPreference.initialize(MapPaintPreference.java:181)
	at org.openstreetmap.josm.Main$6.initialize(Main.java:614)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:707)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:691)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

C:\Data\OSM>cd "C:\Data\OSM\"

C:\Data\OSM>"C:\Program Files (x86)\GnuWin32\bin\wget.exe" -N "http://josm.opens
treetmap.de/josm-latest.jar"
SYSTEM_WGETRC = c:/progra~1/wget/etc/wgetrc
syswgetrc = C:\Program Files (x86)\GnuWin32/etc/wgetrc
--2015-06-21 04:57:56-- http://josm.openstreetmap.de/josm-latest.jar
Herleiden van josm.openstreetmap.de... 78.47.79.181
Verbinding maken met josm.openstreetmap.de|78.47.79.181|:80... verbonden.
HTTP-verzoek is verzonden; wachten op antwoord... 200 OK
Lengte: 10170500 (9,7M) [application/java-archive]
Bestand op server is nieuwer -- ophalen.

--2015-06-21 04:57:56-- http://josm.openstreetmap.de/josm-latest.jar
Verbinding met josm.openstreetmap.de:80 wordt hergebruikt.
HTTP-verzoek is verzonden; wachten op antwoord... 200 OK
Lengte: 10170500 (9,7M) [application/java-archive]
Wordt geschreven naar: josm-latest.jar

100%[======================================>] 10.170.500 1,35M/s in 8,2s

2015-06-21 04:58:04 (1,19 MB/s) - 'josm-latest.jar' opgeslagen [10170500/1017050
0]

C:\Data\OSM>cd "C:\Users\johandc\AppData\Roaming\"

C:\Users\johandc\AppData\Roaming>REM "C:\Program Files (x86)\GnuWin32\bin\wget.e
xe" -N "http://svn.openstreetmap.org/applications/editors/josm/dist/Mapillary.ja
r"

C:\Users\johandc\AppData\Roaming>"C:\data\Java\jre7\bin\java.exe" -Xmx1250M -cla
sspath "C:\Data\OSM\josm-latest.jar;C:\Data\jython2.5.3\jython.jar;C:\Data\jytho
n2.5.3\postgresql-9.2-1002.jdbc4" org.openstreetmap.josm.gui.MainApplication
INFO: loading plugin 'log4j' (version 31231)
WARNING: Detected deprecated 'canvas{background-color}' in 'C:\Data\HOT\HOT-Vali
date.mapcss' which will be removed shortly. Use 'fill-color' instead.
ERROR: Failed to locate image 'presets/relation.png'
WARNING: Could not get presets icon presets/relation.png
ERROR: Failed to locate image 'presets/traffic_calming.png'
WARNING: Could not get presets icon presets/traffic_calming.png
ERROR: Failed to locate image 'presets/stop.png'
WARNING: Could not get presets icon presets/stop.png
ERROR: Failed to locate image 'presets/stop.png'
WARNING: Could not get presets icon presets/stop.png
ERROR: Failed to locate image 'presets/stop.png'
WARNING: Could not get presets icon presets/stop.png
ERROR: Failed to locate image 'presets/crossing.png'
WARNING: Could not get presets icon presets/crossing.png
ERROR: Failed to locate image 'presets/crossing.png'
WARNING: Could not get presets icon presets/crossing.png
INFO: Registered toolbar action tagging_Node Network node overwritten: org.opens
treetmap.josm.gui.tagging.TaggingPreset gets org.openstreetmap.josm.gui.tagging.
TaggingPreset
INFO: Registered toolbar action tagging_Node Network node overwritten: org.opens
treetmap.josm.gui.tagging.TaggingPreset gets org.openstreetmap.josm.gui.tagging.
TaggingPreset
INFO: Registered toolbar action tagging_Node Network node overwritten: org.opens
treetmap.josm.gui.tagging.TaggingPreset gets org.openstreetmap.josm.gui.tagging.
TaggingPreset
ERROR: java.lang.RuntimeException: java.util.concurrent.ExecutionException: java
.lang.IllegalArgumentException: Invalid pseudo class specified: close. Cause: ja
va.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: Inval
id pseudo class specified: close. Cause: java.lang.IllegalArgumentException: Inv
alid pseudo class specified: close
java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.I
llegalArgumentException: Invalid pseudo class specified: close

at org.openstreetmap.josm.Main.<init>(Main.java:632)
at org.openstreetmap.josm.gui.MainApplication.<init>(MainApplication.jav

a:90)

at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:

445)
Caused by: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentExc
eption: Invalid pseudo class specified: close

at java.util.concurrent.FutureTask.report(Unknown Source)
at java.util.concurrent.FutureTask.get(Unknown Source)
at org.openstreetmap.josm.Main.<init>(Main.java:629)
... 2 more

Caused by: java.lang.IllegalArgumentException: Invalid pseudo class specified: c
lose

at org.openstreetmap.josm.gui.mappaint.mapcss.Condition$PseudoClassCondi

tion.createPseudoClassCondition(Condition.java:502)

at org.openstreetmap.josm.gui.mappaint.mapcss.Condition.createPseudoClas

sCondition(Condition.java:74)

at org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.cla

ss_or_pseudoclass(MapCSSParser.java:1452)

at org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.sel

ector(MapCSSParser.java:1060)

at org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.chi

ld_selector(MapCSSParser.java:900)

at org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.rul

e(MapCSSParser.java:870)

at org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.she

et(MapCSSParser.java:854)

at org.openstreetmap.josm.gui.mappaint.mapcss.MapCSSStyleSource.loadStyl

eSource(MapCSSStyleSource.java:394)

at org.openstreetmap.josm.gui.mappaint.MapPaintStyles.loadStyleForFirstT

ime(MapPaintStyles.java:260)

at org.openstreetmap.josm.gui.mappaint.MapPaintStyles.readFromPreference

s(MapPaintStyles.java:253)

at org.openstreetmap.josm.gui.preferences.map.MapPaintPreference.initial

ize(MapPaintPreference.java:181)

at org.openstreetmap.josm.Main$6.initialize(Main.java:614)
at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:707)
at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:691)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

comment:5 Changed 4 years ago by Polyglot

I removed the offending HOT MapCSS style from my preferences, which seems to fix it on my side.

Jo

comment:6 Changed 4 years ago by Klumbumbus

I do not use HOT Mapcss style and I cannot find any mapcss style with :close

comment:7 Changed 4 years ago by simon04

In 8515/josm:

see #11579 - MapCSS: improve error reporting on invalid pseudo classes

comment:10 Changed 4 years ago by Polyglot

Hi Simon,

Shouldn't that be :closed in that style, instead of :closes?

Jo

comment:11 Changed 4 years ago by Don-vip

Ticket #11588 has been marked as a duplicate of this ticket.

comment:12 Changed 4 years ago by Don-vip

In 8521/josm:

see #11593, see #11579 - MapCSS: display mapcss parsing exceptions early in case of later JavaCC exception

comment:13 Changed 4 years ago by Don-vip

I have updated the style to closed. Still, we must find a way to be robust to invalid files (see #11593).

comment:14 Changed 4 years ago by Klumbumbus

Ticket #11597 has been marked as a duplicate of this ticket.

comment:15 Changed 4 years ago by Don-vip

Resolution: fixed
Status: newclosed

comment:16 Changed 4 years ago by Don-vip

Milestone: 15.0715.08

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.