Modify

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#11506 closed defect (wontfix)

Changeset tag created_by can be modified

Reported by: ramyaragupathy Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: changeset description in JOSM Cc: ramya@…

Description (last modified by Don-vip)

While uploading my changesets in JOSM, I tried editing the 'created_by` tag in the description tag.
I believe the ,created_by tag in the changeset description of JOSM should not allow for any such custom edits.
Hence raising a ticket for the same.




Attachments (3)

JOSM.gif (4.0 MB) - added by anonymous 5 years ago.
JOSM.2.gif (4.0 MB) - added by anonymous 5 years ago.
Screen Shot 2015-06-01 at 5.31.38 PM.png (41.6 KB) - added by anonymous 5 years ago.

Change History (11)

Changed 5 years ago by anonymous

Attachment: JOSM.gif added

Changed 5 years ago by anonymous

Attachment: JOSM.2.gif added

Changed 5 years ago by anonymous

comment:1 Changed 5 years ago by Don-vip

Description: modified (diff)

comment:2 Changed 5 years ago by simon04

comment:3 Changed 5 years ago by simon04

Summary: Description tag in ChangesetChangeset tag created_by can be modified

comment:4 Changed 4 years ago by naoliv

ticket:3668#comment:2 says "This is a victim of the OSM freedom. If it was restricted we'd have 10 new open tickets within an hour ;-)"

If somebody is using a non-modified JOSM, I can't see one valid reason to allow to modify created_by.

comment:5 in reply to:  4 Changed 4 years ago by stoecker

Resolution: wontfix
Status: newclosed

Replying to naoliv:

ticket:3668#comment:2 says "This is a victim of the OSM freedom. If it was restricted we'd have 10 new open tickets within an hour ;-)"

If somebody is using a non-modified JOSM, I can't see one valid reason to allow to modify created_by.

There is also no valid reason to forbid it. If someone want to do it, why not? We still live in an free world.

comment:6 Changed 4 years ago by naoliv

Then what is the purpose for created_by after all, if the user can write anything on it?
A free to edit created_by field goes against http://wiki.openstreetmap.org/wiki/Key:created_by

comment:7 in reply to:  6 Changed 4 years ago by stoecker

Replying to naoliv:

Then what is the purpose for created_by after all, if the user can write anything on it?

It tell's what editor was used. And in 99.999% that will be correct. Some people may want to change it in the dialog - or they may change the source - or may change the binaries with an HEX editor. Or the send an API request to modify the changeset after upload or ...

As no harm is done when they do so there is also no reason to make it harder.

A free to edit created_by field goes against http://wiki.openstreetmap.org/wiki/Key:created_by

That page does not state, that this field should no be changeable (which as said above would anyway be impossible).

comment:8 Changed 4 years ago by stoecker

Ticket #13006 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.