Modify

Opened 6 years ago

Closed 6 years ago

#11469 closed defect (duplicate)

Keyboard seems frozen… don't really know how to reproduce

Reported by: jbcorbeille-josm@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

Hello,
This has happened for several months now, but I've never been able to find how to reproduce it. As it is a real problem in the workflow, I finally decided to report it here. I also do not know if it is a JOSM or Java problem.
It usually happens after a few minutes work, but JOSM report does say that there is still memory available.
Everything seems fine, buttons, send, download data, notes, work fine. But the in the "add an attribute" window or send windows, the keyboard does not work (escape key does not work either). The java process is also running at maximum capacity.
JOSM can be blocked like that for either a few seconds (but it is rather rare), more usually for several minutes, the solution being to close JOSM and reopen it.
Do not know if you can do anything about it, but as I said, it is quite a pain and happens too often.

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Revision: 8339
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: stoecker
Last Changed Date: 2015-05-07 17:30:43 +0200 (Thu, 07 May 2015)
Build-Date: 2015-05-08 01:31:23
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8339

Identification: JOSM/1.5 (8339 fr) Windows 7 64-Bit
Memory Usage: 311 MB / 989 MB (105 MB allocated, but free)
Java version: 1.8.0_31, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugins:
- DirectUpload (30892)
- cadastre-fr (30892)
- continuosDownload (1413902943)
- download_along (30892)
- geotools (31068)
- jts (31002)
- mirrored_download (30962)
- poly (31056)
- reltoolbox (31056)
- reverter (31120)
- scripting (30710)
- turnrestrictions (31034)
- utilsplugin2 (31120)

Last errors/warnings:
- W: JCS TMS Cache - error creating URL for tile 13/4154/2818@Bing Aerial Maps: Attribution is not loaded yet
- W: No url returned for: 13/4154/2818@Bing Aerial Maps, skipping

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #11209.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.