Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#11414 closed enhancement (worksforme)

validator rule for public_transport=platform

Reported by: Polyglot Owned by: Polyglot
Priority: normal Milestone:
Component: Core validator Version:
Keywords: public_transport=platform node Cc:

Description

I'm getting messages from the validator claiming public_transport=platform can only be used on way or closed_way. This is not true. It can be used perfectly well on nodes. In that case the node represents the position of the pole. I just checked it on the wiki.

http://wiki.openstreetmap.org/wiki/Buses

All the poles of Belgian transport companies De Lijn, TEC and MIVB/STIB are mapped on nodes. If there is a platform, it is mapped, but that doesn't replace the pole, nor does it get added to the route relations. All the extra details like name, ref, route_ref etc also remain on the node representing the pole. The platform ways and the stop_positions are optional. Nice to have, but not at all crucial. The NODES with

highway=bus_stop
public_transport=platform
bus=yes

railway=tram_stop
public_transport=platform
tram=yes

are what define the bus/tram stops over here and those get the details and those get added to the route relations.

So please correct the validator rule.

Kind regards,

Polyglot

Attachments (0)

Change History (8)

comment:1 by Klumbumbus, 9 years ago

Owner: changed from team to Polyglot
Status: newneedinfo

I do not get this warning. Please doublecheck and attach Status Report and sample .osm file.

comment:2 by Polyglot, 9 years ago

Resolution: fixed
Status: needinfoclosed

How embarassing. I had forgotten to set the platform role.

Jo

comment:3 by Don-vip, 9 years ago

Resolution: fixedinvalid

comment:4 by Polyglot, 9 years ago

Resolution: invalid
Status: closedreopened

However the message of that validator rule is misleading. Instead of saying 'role missing' it says: object must be way or closedway.

Jo

comment:5 by Klumbumbus, 9 years ago

Owner: changed from Polyglot to team
Status: reopenednew

Yes, because the validator thinks that an object without role is a route segment. And for route segments nodes are not allowed. So the validator schould check if a member without role has the tag public_transport=platform or not and then display "...missing role..." or "...wrong object type..."!? (same for the other roles)

comment:6 by simon04, 9 years ago

Owner: changed from team to Polyglot
Status: newneedinfo

How to reproduce (can you add an example)? When adding a public_transport=platform railway=tram_stop tram=yes node to a PTv2 route relation with an empty role, I get "Role member type node does not match accepted list of way/closedway in template Public Transport Route".

comment:7 by Polyglot, 9 years ago

Resolution: fixed
Status: needinfoclosed

I'm not getting this warning anymore. I just tried it.

comment:8 by simon04, 9 years ago

Resolution: fixedworksforme

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Polyglot.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.