Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11404 closed defect (fixed)

[PATCH] High CPU load during tile loading in TMS layer and download box

Reported by: wiktorn Owned by: wiktorn
Priority: normal Milestone: 15.05
Component: Core imagery Version: tested
Keywords: Cc:

Description (last modified by wiktorn)

Because of surplus calls to tileLoadingFinished, there is unnecessary load when tiles are loading. affectes both TMSLayer and SlippyMabBoxChooser.

This is especially visible on slow connections, where tile loading takes some time.

Attachments (1)

fix_high_cpu_load.patch (7.9 KB) - added by wiktorn 6 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 6 years ago by wiktorn

Description: modified (diff)

comment:2 Changed 6 years ago by aceman

Possibly caused by #10902 or other patches of the tile cache rework.

Changed 6 years ago by wiktorn

Attachment: fix_high_cpu_load.patch added

comment:3 Changed 6 years ago by wiktorn

Summary: High CPU load during tile loading in TMS layer and download box[PATCH] High CPU load during tile loading in TMS layer and download box

This patch reduces a lot CPU activity during tile loading.

comment:4 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 8326/josm:

fix #11404 - High CPU load during tile loading in TMS layer and download box (patch by wiktorn)

comment:5 Changed 6 years ago by aceman

Thanks, I think it got a bit better. I don't think it is back to the levels before the tile cache rewrite, but maybe that is not possible with the new infrastructure.

comment:6 Changed 6 years ago by anonymous

Some further improvements are coming within my work at #11437

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain wiktorn.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.