Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11386 closed defect (fixed)

[PATCH] out of memory

Reported by: RAytoun Owned by: wiktorn
Priority: major Milestone: 15.05
Component: Core imagery Version:
Keywords: memory Cc:

Description

I am regularly getting the following error and it is preventing me from working on the Nepal Earthquake
Tasks.
"JOSM is out of memory. Strange things may happen.
Please restart JOSM with the -xXmx###M option where ### is the number of MB assigned to JOSM (eg 256)
Currently 247MB are available to JOSM"

Where do I find this -xXmx###M option to assign more memory to JOSM?

I am on Windows 7 and JOSM Version 8279.

Attachments (1)

fix_out_of_memory.patch (961 bytes) - added by wiktorn 6 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 6 years ago by Don-vip

Resolution: invalid
Status: newclosed

Please don't create bug reports for that. Adding more memory to JOSM is explained on several sites: this one, the osm wiki, the osm help forum, etc.

comment:2 Changed 6 years ago by skyper

comment:3 Changed 6 years ago by wiktorn

Resolution: invalid
Status: closedreopened

I've noticed, that we are leaking BufferedImages, I've noticed more than 2000 BufferedImage instances, though we should have at most 200 (what should reside in memory tile cache).

I will look more deep into this using Memory Analyzer Tool.

comment:4 Changed 6 years ago by wiktorn

Owner: changed from team to wiktorn
Status: reopenednew

comment:5 Changed 6 years ago by wiktorn

Component: unspecifiedCore imagery

comment:6 Changed 6 years ago by stoecker

A note: Please don't open old tickets only because the topic seems equal :-)

Changed 6 years ago by wiktorn

Attachment: fix_out_of_memory.patch added

comment:7 in reply to:  6 Changed 6 years ago by wiktorn

Summary: out of memory[PATCH] out of memory

The topic gained my attention, as I've seen yesterday also the same message. I did some preliminary digging with VisualVM. But as I worked with MAT, I confirmed, that the problem lies only in size of memory cache.

With 200 objects in cache, I see memory usage ~100MB after System.gc(), which is quite reasonable.

1000 might be far too high for a default.

Replying to stoecker:

A note: Please don't open old tickets only because the topic seems equal :-)

In my opinion, this gives users a better felling of support from developers.

Last edited 6 years ago by wiktorn (previous) (diff)

comment:8 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 8327/josm:

fix #11386 - reduce cache memory footprint (patch by wiktorn)

comment:9 Changed 6 years ago by Klumbumbus

Ticket #11406 has been marked as a duplicate of this ticket.

comment:10 Changed 6 years ago by bastiK

High memory use has been reported for r8339 on the forum: http://forum.openstreetmap.org/viewtopic.php?pid=502326#p502326

He sees more than 1 GB memory used by JOSM according to the Windows task manager.

@wiktorn: Can you check if this is reproduceable?

comment:11 Changed 6 years ago by Don-vip

Milestone: 15.05
Type: enhancementdefect

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain wiktorn.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.