Modify

Opened 4 years ago

Closed 4 years ago

#11383 closed defect (fixed)

JOSM froze and unexpected Exception error is the only thing available

Reported by: beth_gis@… Owned by: team
Priority: normal Milestone: 15.05
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. I was editing an OSM from http://tasks.hotosm.org/project/1009#task/83
  2. I was looking through the imagery available, and tried loading the last file I worked on
  3. The new file was gone, the last file appeared, then everything froze

What is the expected result?

I expected I could go back to the http://tasks.hotosm.org/project/1009#task/83

What happens instead?

all of JOSM frozehttps://farm8.staticflickr.com/7683/16684348934_1c5bbab657_m.jpg

Please provide any additional information below. Attach a screenshot if possible.

Also, I just noticed that I have java 32 bit installed on my 64 bit windows 7 laptop. I might have chosen a 64 bit JOSM if I got a choice when I installed JOSM (2 days ago). I haven't had this problem before.

Revision: 8279
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Klumbumbus
Last Changed Date: 2015-04-26 22:42:34 +0200 (Sun, 26 Apr 2015)
Build-Date: 2015-04-27 01:31:19
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8279

Identification: JOSM/1.5 (8279 en) Windows 7 64-Bit
Memory Usage: 247 MB / 247 MB (135 MB allocated, but free)
Java version: 1.8.0_45, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Djava.security.manager, -Djava.security.policy=file:C:\Program Files (x86)\Java\jre1.8.0_45\lib\security\javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>\bin, -Djnlpx.origFilenameArg=C:\Users\cartwright\AppData\LocalLow\Sun\Java\Deployment\cache\6.0\56\1ee8cfb8-171a4111, -Djnlpx.remove=false, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.splashport=60173, -Djnlp.application.href=https://josm.openstreetmap.de/download/josm.jnlp, -Djnlpx.jvm=<java.home>\bin\javaw.exe, -Djnlpx.vmargs=LURqYXZhLnV0aWwuQXJyYXlzLnVzZUxlZ2FjeU1lcmdlU29ydD10cnVlAC1Eam5scC5hcHBsaWNhdGlvbi5ocmVmPWh0dHBzOi8vam9zbS5vcGVuc3RyZWV0bWFwLmRlL2Rvd25sb2FkL2pvc20uam5scAA=]


Last errors/warnings:
- E: java.lang.IndexOutOfBoundsException: Index: 3, Size: 3
- E: java.lang.IndexOutOfBoundsException: Index: 3, Size: 3
- E: java.lang.IndexOutOfBoundsException: Index: 3, Size: 3
- E: java.lang.IndexOutOfBoundsException: Index: 3, Size: 3
- E: java.lang.IndexOutOfBoundsException: Index: 3, Size: 3

java.lang.IndexOutOfBoundsException: Index: 3, Size: 3
	at java.util.ArrayList.rangeCheck(Unknown Source)
	at java.util.ArrayList.get(Unknown Source)
	at java.util.Collections$UnmodifiableList.get(Unknown Source)
	at org.openstreetmap.josm.gui.dialogs.LayerListDialog$LayerListModel.setValueAt(LayerListDialog.java:1501)
	at javax.swing.JTable.setValueAt(Unknown Source)
	at javax.swing.JTable.editingStopped(Unknown Source)
	at javax.swing.AbstractCellEditor.fireEditingStopped(Unknown Source)
	at javax.swing.DefaultCellEditor$EditorDelegate.stopCellEditing(Unknown Source)
	at javax.swing.DefaultCellEditor.stopCellEditing(Unknown Source)
	at javax.swing.JTable$CellEditorRemover.propertyChange(Unknown Source)
	at java.beans.PropertyChangeSupport.fire(Unknown Source)
	at java.beans.PropertyChangeSupport.firePropertyChange(Unknown Source)
	at java.beans.PropertyChangeSupport.firePropertyChange(Unknown Source)
	at java.awt.KeyboardFocusManager.firePropertyChange(Unknown Source)
	at java.awt.KeyboardFocusManager.setGlobalPermanentFocusOwner(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (4)

comment:1 Changed 4 years ago by rickmastfan67

JOSM runs in whatever mode that your Java is. So, if you install the x64 Java, JOSM will run in x64 too.

Create a shortcut on your Desktop with this information:

Target: "C:\Program Files\Java\jre7\bin\java.exe" -Xmx2048M -jar josm-tested.jar
Start in: "C:\Program Files (x86)\JOSM"

That's how to get JOSM to run and have more than enough memory to run it properly in x64 mode once you have x64 Java installed on your computer.

NOTE: You need to change the 'target' code to adjust to wherever you have Java installed. So, if you have Java8 installed, change the 'jre7' part to 'jre8'.

Last edited 4 years ago by rickmastfan67 (previous) (diff)

comment:2 Changed 4 years ago by Don-vip

Looks like a very old and rare problem of JOSM, difficult to reproduce and never fixed: #5808, #6444, #6555

comment:3 Changed 4 years ago by Don-vip

Milestone: 15.05

comment:4 Changed 4 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 8293/josm:

fix #11383 - IndexOutOfBoundsException in LayerListDialog

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.