Modify

Opened 9 years ago

Closed 9 years ago

#11290 closed defect (fixed)

House Number field needs a minimum width (OSX)

Reported by: dobratzp Owned by: team
Priority: normal Milestone: 15.05
Component: Core Version:
Keywords: template_report macosx laf nimbus aqua Cc: flaimo

Description (last modified by Klumbumbus)

What steps will reproduce the problem?

  1. Create a new Node or closed Way.
  2. Select Presets => Annotation => Addresses
  3. Type a number into the House Number field.

What is the expected result?

You expect to see the number as you type it.

What happens instead?

The number is not displayed at all because the text box is too narrow.

Please provide any additional information below. Attach a screenshot if possible.

If you resize the window after entering a house number, then the text box grows to hold the entered number and retains a minimum width so that the number is displayed even if you make the dialog box smaller.

If you are editing an existing object which already has the addr:housenumber tag set, then the house number text box starts out big enough to display the number.

The house number text box should have a minimum width so that it will display at least 6 characters or so to accommodate most house numbers.

address annotation on a new object

Revision: 8159
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: stoecker
Last Changed Date: 2015-03-29 14:37:50 +0200 (Sun, 29 Mar 2015)
Build-Date: 2015-03-30 01:30:55
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8159

Identification: JOSM/1.5 (8159 en) Mac OS X 10.10.2
Memory Usage: 366 MB / 1820 MB (225 MB allocated, but free)
Java version: 1.8.0_25, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- FixAddresses (30892)
- OpeningHoursEditor (30962)
- reverter (30990)
- utilsplugin2 (31072)

Attachments (2)

addr_new.png (60.0 KB ) - added by dobratzp 9 years ago.
address annotation on a new object
addr_existing.png (61.5 KB ) - added by dobratzp 9 years ago.
address annotation window after selecting an existing object

Download all attachments as: .zip

Change History (17)

by dobratzp, 9 years ago

Attachment: addr_new.png added

address annotation on a new object

by dobratzp, 9 years ago

Attachment: addr_existing.png added

address annotation window after selecting an existing object

comment:1 by Klumbumbus, 9 years ago

Description: modified (diff)

comment:2 by Don-vip, 9 years ago

Owner: changed from team to dobratzp
Status: newneedinfo

Does it still happen with java 8u40?

comment:3 by dobratzp, 9 years ago

Yes, I upgraded to JDK 8u40 and JOSM has the same behavior.

$ java -version
java version "1.8.0_40"
Java(TM) SE Runtime Environment (build 1.8.0_40-b27)
Java HotSpot(TM) 64-Bit Server VM (build 25.40-b25, mixed mode)

comment:4 by Don-vip, 9 years ago

Owner: changed from dobratzp to team
Status: needinfonew

comment:5 by simon04, 9 years ago

Cc: osx added
Summary: House Number field needs a minimum widthHouse Number field needs a minimum width (OSX)

Only OSX seems affected since other Java Runtimes do not display such wide buttons (–2 … +2)

comment:6 by Don-vip, 9 years ago

Cc: osx removed
Keywords: macosx added

comment:7 by Klumbumbus, 9 years ago

Ticket #11423 has been marked as a duplicate of this ticket.

comment:8 by Klumbumbus, 9 years ago

Cc: flaimo added

comment:9 by Aun Johnsen <lists@…>, 9 years ago

Same problem

java -version
java version "1.8.0_40-ea"
Java(TM) SE Runtime Environment (build 1.8.0_40-ea-b07)
Java HotSpot(TM) 64-Bit Server VM (build 25.40-b11, mixed mode)

It's been persistent through at least 4 stable releases of JOSM

in reply to:  9 comment:10 by Don-vip, 9 years ago

Replying to Aun Johnsen <lists@…>:

Same problem

Yes, we know the problem happens with 8u40. Testing with 8u45 could be useful, but I fear we need to write some OSX specific code to handle these wide buttons, and nobody did that yet.

comment:11 by anonymous, 9 years ago

Problem also exists with Java 8u45: #11423

comment:12 by Aun Johnsen <lists@…>, 9 years ago

I will look into upgrading Java over the weekend if my offshore connection allows. Just mentioned my version as I saw I had different build than the one mentioned

comment:13 by Don-vip, 9 years ago

Yes, it's older. "ea" means "early access", so that's a beta release of 8u40.

comment:14 by Don-vip, 9 years ago

Keywords: laf nimbus aqua added
Milestone: 15.05

comment:15 by Don-vip, 9 years ago

Resolution: fixed
Status: newclosed

In 8358/josm:

fix #11290 - fix width of auto_increment buttons for Aqua & Nimbus look and feels

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.