Modify

Opened 5 years ago

Closed 5 years ago

#11267 closed defect (duplicate)

i get this error while exporting as osm.pbf

Reported by: selmihh@… Owned by: Don-vip
Priority: normal Milestone:
Component: Plugin pbf Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-03-02 02:30:58
Last Changed Author: Don-vip
Revision: 8109
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-03-02 00:13:51 +0100 (Mon, 02 Mar 2015)
Last Changed Rev: 8109

Identification: JOSM/1.5 (8109 fr) Windows 7 64-Bit
Memory Usage: 362 MB / 910 MB (134 MB allocated, but free)
Java version: 1.7.0_60, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- pbf (31010)
- turnrestrictions (31034)

Last errors/warnings:
- E: java.lang.NullPointerException

java.lang.NullPointerException
	at crosby.binary.StringTable.getIndex(StringTable.java:54)
	at org.openstreetmap.josm.plugins.pbf.io.PbfWriter$PbfSerializer$Prim.serializeMetadataDense(PbfWriter.java:109)
	at org.openstreetmap.josm.plugins.pbf.io.PbfWriter$PbfSerializer$NodeGroup.serializeDense(PbfWriter.java:171)
	at org.openstreetmap.josm.plugins.pbf.io.PbfWriter$PbfSerializer$NodeGroup.serialize(PbfWriter.java:146)
	at crosby.binary.BinarySerializer.processBatch(BinarySerializer.java:121)
	at org.openstreetmap.josm.plugins.pbf.io.PbfWriter$PbfSerializer.complete(PbfWriter.java:465)
	at org.openstreetmap.josm.plugins.pbf.io.PbfWriter.writeData(PbfWriter.java:479)
	at org.openstreetmap.josm.plugins.pbf.io.PbfWriter.writeLayer(PbfWriter.java:474)
	at org.openstreetmap.josm.plugins.pbf.io.PbfExporter.doSave(PbfExporter.java:32)
	at org.openstreetmap.josm.io.OsmExporter.save(OsmExporter.java:92)
	at org.openstreetmap.josm.io.OsmExporter.exportData(OsmExporter.java:67)
	at org.openstreetmap.josm.io.OsmExporter.exportData(OsmExporter.java:54)
	at org.openstreetmap.josm.actions.SaveActionBase.doInternalSave(SaveActionBase.java:84)
	at org.openstreetmap.josm.actions.SaveActionBase.doSave(SaveActionBase.java:56)
	at org.openstreetmap.josm.actions.SaveActionBase.doSave(SaveActionBase.java:46)
	at org.openstreetmap.josm.actions.SaveActionBase.actionPerformed(SaveActionBase.java:36)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$200(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
	Suppressed: java.lang.NullPointerException
		at crosby.binary.StringTable.getIndex(StringTable.java:54)
		at org.openstreetmap.josm.plugins.pbf.io.PbfWriter$PbfSerializer$Prim.serializeMetadataDense(PbfWriter.java:109)
		at org.openstreetmap.josm.plugins.pbf.io.PbfWriter$PbfSerializer$NodeGroup.serializeDense(PbfWriter.java:171)
		at org.openstreetmap.josm.plugins.pbf.io.PbfWriter$PbfSerializer$NodeGroup.serialize(PbfWriter.java:146)
		at crosby.binary.BinarySerializer.processBatch(BinarySerializer.java:121)
		at crosby.binary.BinarySerializer.flush(BinarySerializer.java:96)
		at crosby.binary.BinarySerializer.close(BinarySerializer.java:101)
		at org.openstreetmap.josm.plugins.pbf.io.PbfWriter.close(PbfWriter.java:484)
		at org.openstreetmap.josm.plugins.pbf.io.PbfExporter.doSave(PbfExporter.java:36)
		... 44 more

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by stoecker

Component: CorePlugin pbf
Owner: changed from team to Don-vip

comment:2 Changed 5 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #11169.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.