Modify

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#11184 closed defect (fixed)

"split way" is splitting an other way instead of the selected

Reported by: mdk Owned by: team
Priority: normal Milestone: 15.04
Component: Core Version: latest
Keywords: Cc:

Description (last modified by mdk)

I found that "split way" action (P) will spit a different way instead of the selected in some cases. I attached a sample file.

To reproduce:

  • load file
  • select landuse area
  • multiselect the node where the highway crosses the landuse
  • press "P"

What should happen:

  • the landuse should be splitted into two areas

What happens instead:

  • the highway is added to the selection
  • the highway is splitted into two parts

I think the problem is the self intersecting (illegal) landuse area. The easiest way to fix this error is splitting the area. But this is not possible, because an other way will be splitted instead.

Btw: if there wasen't an other way (delete highway in example), the split works as expected.

Attachments (1)

splitwaybug.osm (1.7 KB) - added by mdk 5 years ago.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by mdk

Attachment: splitwaybug.osm added

comment:1 Changed 5 years ago by mdk

Description: modified (diff)

comment:2 Changed 4 years ago by Balaitous

Resolution: fixed
Status: newclosed

In 8276/josm:

fix #11184 - "split way" is splitting an other way instead of the selected.
The case where the selected node is both one end and an intermediate node of the selected way was not taken into account.
Add test case.

comment:3 Changed 4 years ago by mdk

Milestone: 15.04

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.