Modify

Opened 5 years ago

Closed 5 years ago

#11177 closed defect (fixed)

Notes: upload before deleting layer doesn't work

Reported by: malenki Owned by: ToeBee
Priority: normal Milestone: 15.05
Component: Core notes Version: latest
Keywords: Cc:

Description (last modified by Don-vip)

The functionality of the "Save or upload" function before deleting a layer or closing JOSM with unsaved data is useful but does not work with built in notes.
When a note was created and the layer is to be deleted the "Save or upload" dialog shows up. Clicking "upload" results in the error message

"An upload and/or save operation of one layer with modifications was cancelled or has failed"


See also #11176

Attachments (1)

2015-02-27_233106_scr.png (84.7 KB) - added by malenki 5 years ago.

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by malenki

Attachment: 2015-02-27_233106_scr.png added

comment:1 Changed 5 years ago by Don-vip

Description: modified (diff)

No other error message on console?

comment:2 Changed 5 years ago by ToeBee

I think I failed to implement some abstract upload task or something that the dialog is expecting in this case. I will look at it again this weekend.

comment:3 Changed 5 years ago by Don-vip

Ticket #11532 has been marked as a duplicate of this ticket.

comment:4 Changed 5 years ago by Don-vip

Milestone: 15.05

comment:5 Changed 5 years ago by Don-vip

Ticket #11531 has been marked as a duplicate of this ticket.

comment:6 Changed 5 years ago by malenki

It seems I am getting old. Sorry for the duplicates.

comment:7 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 8474/josm:

fix #11177 - Notes: upload before deleting layer doesn't work

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain ToeBee.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.