Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11170 closed defect (duplicate)

JOSM refuses connection with Firefox on https. No problem when using http. Chrome and IE are doing fine with https and http.

Reported by: Gilbert54 Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. open a map with openstreetmap.org in firefox using https
  2. start JOSM, don't download a map. JOSM has https enabled and certificate installed.
  3. launch edit session with JOSM remote control from browser

What is the expected result?

JOSM dowloads map area shown in browser

What happens instead?

FF reports "Editing failed - make sure JOSM or Merkaartor is loaded and the remote control option is enabled". Fiddler shows that destination (JOSM)actively refuses connection with browser.

Please provide any additional information below. Attach a screenshot if possible.

FF version 35.0.1
OSM url = https://www.openstreetmap.org/way/148011489

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-02-01 02:33:54
Last Changed Author: Don-vip
Revision: 7995
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-01-31 15:17:59 +0100 (Sat, 31 Jan 2015)
Last Changed Rev: 7995

Identification: JOSM/1.5 (7995 en_GB) Windows 7 64-Bit
Memory Usage: 364 MB / 910 MB (240 MB allocated, but free)
Java version: 1.7.0_71, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM

Plugins:
- HouseNumberTaggingTool (30892)
- ShapeTools (1000)
- buildings_tools (30955)
- download_along (30892)
- reltoolbox (30892)
- reverter (30953)
- terracer (30892)
- turnlanes (30892)
- turnrestrictions (30892)
- utilsplugin2 (30892)
- wikipedia (30892)

Last errors/warnings:
- W: Could not get presets icon 
- E: Failed to locate image 'presets/soccer.png'
- W: Could not get presets icon presets/soccer.png
- E: Failed to locate image 'presets/State_Public.png'
- W: Could not get presets icon presets/State_Public.png

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #10033.

comment:2 Changed 5 years ago by anonymous

Open https://127.0.0.1:8112/ and accept certificate.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.