Modify

Opened 5 years ago

Closed 5 years ago

#11105 closed defect (fixed)

Error when undo drawing

Reported by: anonymous Owned by: team
Priority: major Milestone: 15.02
Component: Core Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Draw line with nodes 1,2,3,4
  2. Select node 3
  3. CTRL+Z one time
  4. Add to selection way
  5. Add to selection node 2
  6. Switch to draw mode
  7. Error error error, must close josm

Please provide any additional information below. Attach a screenshot if possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-02-11 02:34:32
Last Changed Author: Klumbumbus
Revision: 8045
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-02-11 00:55:31 +0100 (Wed, 11 Feb 2015)
Last Changed Rev: 8045

Identification: JOSM/1.5 (8045 pl) Linux Ubuntu 14.04.1 LTS
Memory Usage: 477 MB / 869 MB (159 MB allocated, but free)
Java version: 1.7.0_75, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u75-2.5.4-1~trusty1
Dataset consistency test: No problems found

Plugins:
- CADTools (1002)
- InfoMode (30892)
- OpeningHoursEditor (30962)
- PicLayer (30962)
- editgpx (30892)
- photo_geotagging (30967)
- photoadjust (30964)
- reverter (30953)
- tag2link (30962)

Last errors/warnings:
- E: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=-5551 version=0 MV lat=51.82387906994501,lon=19.418792262968925}

org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=-5551 version=0 MV lat=51.82387906994501,lon=19.418792262968925}
	at org.openstreetmap.josm.data.osm.OsmPrimitive.checkDataset(OsmPrimitive.java:334)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:1030)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:1051)
	at org.openstreetmap.josm.actions.mapmode.DrawAction.getWayForNode(DrawAction.java:925)
	at org.openstreetmap.josm.actions.mapmode.DrawAction.redrawIfRequired(DrawAction.java:180)
	at org.openstreetmap.josm.actions.mapmode.DrawAction.addHighlighting(DrawAction.java:1081)
	at org.openstreetmap.josm.actions.mapmode.DrawAction.mouseMoved(DrawAction.java:747)
	at java.awt.AWTEventMulticaster.mouseMoved(AWTEventMulticaster.java:330)
	at java.awt.Component.processMouseMotionEvent(Component.java:6561)
	at javax.swing.JComponent.processMouseMotionEvent(JComponent.java:3330)
	at java.awt.Component.processEvent(Component.java:6285)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4872)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4505)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:740)
	at java.awt.EventQueue.access$300(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:699)
	at java.awt.EventQueue$3.run(EventQueue.java:697)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:713)
	at java.awt.EventQueue$4.run(EventQueue.java:711)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:710)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (1)

Zrzut ekranu z 2015-02-11 23:12:39.png (15.3 KB) - added by anonymous 5 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 5 years ago by stoecker

Milestone: 15.02
Priority: normalmajor

Looks like a fine description, maybe a change to catch another (the last one) of these beasts?

comment:2 Changed 5 years ago by anonymous

Edit: don't must close josm. Pressing ESC is enough to escape draw mode.

comment:3 in reply to:  1 Changed 5 years ago by skyper

Replying to stoecker:

(the last one) of these beasts?

Definitely not the last one as we are only talking about one data layer ATM and not about merging and multiple layers.

comment:4 Changed 5 years ago by Don-vip

Owner: changed from team to anonymous
Status: newneedinfo

Can't reproduce, can you please post a screenshot and describe exactly how you do each step (mouse, keyboard shortcuts ?). This must be a very special condition that triggers this bug.

Changed 5 years ago by anonymous

comment:5 Changed 5 years ago by anonymous

1.Open JOSM (my version 8045)
2.Add new layer CTRL+N
3.Zoom in to ~20m using scroll
4.Press A to draw mode
5.Draw not closed way X with nodes no. 1,2,3,4
6.Press S to select mode
7.Select node no. 2,3 and way X
8.Press CTRL+SHIFT+Z (CTRL+Y is default)
9.Press A to draw mode
10.Move mouse
11.Error

comment:6 in reply to:  5 Changed 5 years ago by anonymous

Replying to anonymous:

8.Press CTRL+SHIFT+Z (CTRL+Y is default)

Sorry, should be - 8.Press CTRL+Z to undo

comment:7 Changed 5 years ago by Don-vip

Owner: changed from anonymous to team
Status: needinfonew

Reproduced, thanks!

comment:8 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 8064/josm:

fix #11105 - DataIntegrityProblemException when undo drawing

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.