Modify

Opened 5 years ago

Closed 3 weeks ago

Last modified 13 days ago

#11042 closed defect (duplicate)

Too large confirmation dialog

Reported by: verdy_p Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: Cc:

Description (last modified by Don-vip)

Sometimes we get really too large confirmation dialogs that do not fit on display. The dialog refuses to be moved up as it already reaches the top of screen and the (modal) window refuses to go higher (it would hide the top title bar and suste menu allowing to move down the window again.

For this reason, it is impossible to click on any proposed action (OK/cancel buttons, as well as the checkbox to never ask again) because they are off the screen.

Please make sure that any long text displayed in such dialogs are embedded in a scrollabe widget whose maximum width and height will not cause the confirmation dialog window to overflow; we will still be able to scroll the content, and actions buttons will be reachable !

Attachment: screenshot of such dialog, here for the confirmation before combining two objets when the listt of its parent relations is quite long (here 44 relations are listed, most of them are bus routes).

example of a too large confirmation dialog which does not fit the screen size.

Attachments (1)

JOSM-too-large-combination-confimation-dialog.png (319.0 KB) - added by verdy_p 5 years ago.
example of a too large confirmation dialog which does not fit the screen size.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by verdy_p

example of a too large confirmation dialog which does not fit the screen size.

comment:1 Changed 5 years ago by Don-vip

Description: modified (diff)

comment:2 Changed 3 weeks ago by simon04

Resolution: duplicate
Status: newclosed

Closed as duplicate of #12343.

comment:3 Changed 2 weeks ago by anonymous

Actually, bug 12343 was the duplicate create later.
You forgot this bug 11042 submitted 5 years ago !

comment:4 Changed 13 days ago by simon04

Yes, normally we keep the older ticket. In this case however, two commits were referring the newer ticket. Having >1000 open tickets, we sometimes overlook existing older ones.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.